HDU 1061 Rightmost Digit (矩阵快速幂)

Rightmost Digit

http://acm.hdu.edu.cn/showproblem.php?pid=1061

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 21580    Accepted Submission(s): 8242

Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the rightmost digit of N^N.
 
Sample Input
 
2
3
4
 
Sample Output
 
7
6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 
 
注意不断模10,否则可能溢出
 
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

int solve(int a,int b,int k){
    while(k){
        if(k&1){
            b=a*b%10;
        }
        a=a*a%10;
        k>>=1;
    }
    return b;
}

int main(){

    //freopen("input.txt","r",stdin);

    int t,n;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        printf("%d\n",solve(n%10,1,n));
    }
    return 0;
}

 

 
posted @ 2012-12-29 16:37  Jack Ge  阅读(201)  评论(0编辑  收藏  举报