HDU 1102 Constructing Roads(两种基本方法:Prim | Kruskal)

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9149    Accepted Submission(s): 3383

Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.
We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 
Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.
Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 
Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
 
Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2
 
Sample Output
179
 
Source
 
Recommend
Eddy
 
 
 
 
解法一:Prim算法
 
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int N=110;
const int INF=0x3f3f3f3f;

int n,ans;
int map[N][N],dis[N],vis[N];

void Prim(){
    int i;
    for(i=1;i<=n;i++){
        dis[i]=map[1][i];
        vis[i]=0;
    }
    dis[1]=0;
    vis[1]=1;
    int j,k,tmp;
    for(i=1;i<=n;i++){
        tmp=INF;
        for(j=1;j<=n;j++)
            if(!vis[j] && tmp>dis[j]){
                k=j;
                tmp=dis[j];
            }
        if(tmp==INF)
            break;
        vis[k]=1;
        ans+=dis[k];
        for(j=1;j<=n;j++)
            if(!vis[j] && dis[j]>map[k][j])
                dis[j]=map[k][j];
    }
}

int main(){

    //freopen("input.txt","r",stdin);

    while(~scanf("%d",&n)){
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                scanf("%d",&map[i][j]);
        int q,a,b;
        scanf("%d",&q);
        while(q--){
            scanf("%d%d",&a,&b);
            map[a][b]=map[b][a]=0;
        }
        ans=0;
        Prim();
        printf("%d\n",ans);
    }
    return 0;
}

 

 

算法二:Kruskal

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

const int N=110;

struct Edge{
    int u,v;
    int cap;
}edge[N*N];

int n,cnt,ans;
int father[N],rank[N];

void addedge(int cu,int cv,int cw){
    edge[cnt].u=cu;     edge[cnt].v=cv;     edge[cnt].cap=cw;
    cnt++;
}

void makeSet(){
    for(int i=1;i<=n;i++){
        father[i]=i;
        rank[i]=1;
    }
}

int findSet(int x){
    if(x!=father[x]){
        father[x]=findSet(father[x]);
    }
    return father[x];
}

int cmp(Edge a,Edge b){
    return a.cap<b.cap;
}

void Kruskal(){
    sort(edge,edge+cnt,cmp);
    for(int i=0;i<cnt;i++){
        int fx=findSet(edge[i].u);
        int fy=findSet(edge[i].v);
        if(fx==fy)
            continue;
        ans+=edge[i].cap;
        if(rank[fx]>=rank[fy]){
            father[fy]=fx;
            rank[fx]+=rank[fy];
        }else{
            father[fx]=fy;
            rank[fy]+=rank[fx];
        }
    }
}

int main(){

    //freopen("input.txt","r",stdin);

    while(~scanf("%d",&n)){
        makeSet();
        cnt=0;
        int w;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++){
                scanf("%d",&w);
                addedge(i,j,w);
            }
        int q,u,v;
        scanf("%d",&q);
        while(q--){
            scanf("%d%d",&u,&v);
            int fx=findSet(u);
            int fy=findSet(v);
            if(rank[fx]>=rank[fy]){
                father[fy]=fx;
                rank[fx]+=rank[fy];
            }else{
                father[fx]=fy;
                rank[fy]+=rank[fx];
            }
        }
        ans=0;
        Kruskal();
        printf("%d\n",ans);
    }
    return 0;
}

 

posted @ 2012-12-18 17:44  Jack Ge  阅读(3782)  评论(0编辑  收藏  举报