POJ 2155 Matrix (二维树状数组)

Matrix
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 14123   Accepted: 5337

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng
 
此题大意:给你一个2维平面,C:(X1,Y1)(X2,Y2)就是将这里范围的点改变:0->1、1->0,Q:(x,y)就是问这个点是什么。
 
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int N=1010;

int n,arr[N][N];

int lowbit(int x){
    return x&(-x);
}

void update(int i,int j,int val){
    while(i<=n){
        int tmpj=j;
        while(tmpj<=n){
            arr[i][tmpj]+=val;
            tmpj+=lowbit(tmpj);
        }
        i+=lowbit(i);
    }
}

int Sum(int i,int j){
    int ans=0;
    while(i>0){
        int tmpj=j;
        while(tmpj>0){
            ans+=arr[i][tmpj];
            tmpj-=lowbit(tmpj);
        }
        i-=lowbit(i);
    }
    return ans;
}

int main(){

    //freopen("input.txt","r",stdin);

    int t,q;
    scanf("%d",&t);
    char op[3];
    while(t--){
        scanf("%d%d",&n,&q);
        memset(arr,0,sizeof(arr));
        int x1,y1,x2,y2;
        while(q--){
            scanf("%s",op);
            if(op[0]=='C'){
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                update(x2+1,y2+1,1);
                update(x2+1,y1,1);
                update(x1,y2+1,1);
                update(x1,y1,1);
            }else if(op[0]=='Q'){
                scanf("%d%d",&x1,&y1);
                printf("%d\n",Sum(x1,y1)&1);    //该点的值就是sum(x,y) 
            }
        }
        if(t!=0)
            printf("\n");
    }
    return 0;
}

 

 
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int N=1010;

int array[N][N];
int n;

int lowbit(int x){
    return x&(-x);
}

void update(int i,int j){
    int tmp;
    while(i>0){
        tmp=j;
        while(tmp>0){
            array[i][tmp]^=1;
            tmp-=lowbit(tmp);
        }
        i-=lowbit(i);
    }
}

int query(int i,int j){
    int ans=0;
    int tmp;
    while(i<=n){
        tmp=j;
        while(tmp<=n){
            ans^=array[i][tmp];
            tmp+=lowbit(tmp);
        }
        i+=lowbit(i);
    }
    return ans;
}

int main(){

    //freopen("input.txt","r",stdin);

    int t,m;
    char op;
    scanf("%d",&t);
    while(t--){
        memset(array,0,sizeof(array));
        scanf("%d%d",&n,&m);
        int x1,y1,x2,y2;
        while(m--){
            getchar();
            scanf("%c",&op);
            if(op=='C'){
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                update(x2,y2);
                update(x1-1,y2);
                update(x2,y1-1);
                update(x1-1,y1-1);
            }else{
                scanf("%d%d",&x1,&y1);
                printf("%d\n",query(x1,y1));
            }
        }
        if(t!=0)
            printf("\n");
    }
    return 0;
}

 

posted @ 2013-04-23 23:18  Jack Ge  阅读(372)  评论(0编辑  收藏  举报