POJ 2886 Who Gets the Most Candies? (线段树)

Who Gets the Most Candies?
Time Limit: 5000MS   Memory Limit: 131072K
Total Submissions: 7388   Accepted: 2184
Case Time Limit: 2000MS

Description

N children are sitting in a circle to play a game.

The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the others the integer on his card and jumps out of the circle. The integer on his card tells the next child to jump out. Let A denote the integer. If A is positive, the next child will be the A-th child to the left. If A is negative, the next child will be the (A)-th child to the right.

The game lasts until all children have jumped out of the circle. During the game, the p-th child jumping out will get F(p) candies where F(p) is the number of positive integers that perfectly divide p. Who gets the most candies?

Input

There are several test cases in the input. Each test case starts with two integers N (0 < N ≤ 500,000) and K (1 ≤ K ≤ N) on the first line. The next N lines contains the names of the children (consisting of at most 10 letters) and the integers (non-zero with magnitudes within 108) on their cards in increasing order of the children’s numbers, a name and an integer separated by a single space in a line with no leading or trailing spaces.

Output

Output one line for each test case containing the name of the luckiest child and the number of candies he/she gets. If ties occur, always choose the child who jumps out of the circle first.

Sample Input

4 2
Tom 2
Jack 4
Mary -1
Sam 1

Sample Output

Sam 3

Source

 
 
题意:N个人围成一圈第一个人跳出圈后会告诉你下一个谁跳出来跳出来的人(如果他手上拿的数为正数,从他左边数A个,反之,从他右边数A个) 跳出来的人所得到的糖果数量和他跳出的顺序有关 所得的糖果数为 (假设他是第k个跳出的) 则他得到的糖数为k能被多少个数正数 比如说 k = 6 ;  6 = 1*2*3*6 所以他得到的糖数为4;

思路:线段数 先算出N个人中,是第几个人(id)跳出来得到的糖果最多。然后模拟id遍 长到第id个人的name
线段树的结点中保存该区间内还剩多少人,每次update 删除一个人。
 
  1. /* a为反素数表,b为对应的约数个数 */  
  2. int a[37]={1,2,4,6,12,24,36,48,60,120,180,240,360,720,840,1260,1680,2520,5040,7560,10080,15120,20160,25200,27720,45360,50400,  
  3.            55440,83160,110880,166320,221760,277200,332640,498960,500001};  
  4. int b[37]={1,2,3,4,6,8,9,10,12,16,18,20,24,30,32,36,40,48,60,64,72,80,84,90,96,100,108,120,128,144,160,168,180,192,200,1314521};  

为啥用这个,???

 

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

#define L(rt) (rt<<1)
#define R(rt) (rt<<1|1)

const int N=500010;

int n,id;

struct node{
    int l,r,sum;    //sum 表 该区间剩余人数
}tree[N*3];

struct date{
    int val;
    char name[15];
}boy[N];

int ans[N]; //ans[i]保存第i个人跳出能得到的糖果数量

void build(int l,int r,int rt){
    tree[rt].l=l;
    tree[rt].r=r;
    tree[rt].sum=r-l+1;
    if(l==r)
        return ;
    int mid=(l+r)>>1;
    build(l,mid,L(rt));
    build(mid+1,r,R(rt));
}

int update(int key,int rt){
    tree[rt].sum--;
    if(tree[rt].l==tree[rt].r)
        return tree[rt].l;
    if(tree[L(rt)].sum>=key)
        return update(key,L(rt));
    else
        return update(key-tree[L(rt)].sum,R(rt));
}

void Solve(){   //计算ans
    memset(ans,0,sizeof(ans));
    for(int i=1;i<=n;i++){
        ans[i]++;
        for(int j=2*i;j<=n;j+=i)
            ans[j]++;
    }
    int max=ans[1];
    id=1;
    for(int i=2;i<=n;i++)   //找出第几个人跳出获得的糖最多
        if(ans[i]>max){
            max=ans[i];
            id=i;
        }
}

int main(){

    //freopen("input.txt","r",stdin);

    int i,k,mod;
    while(~scanf("%d%d",&n,&k)){
        Solve();
        for(i=1;i<=n;i++)
            scanf("%s%d",boy[i].name,&boy[i].val);
        build(1,n,1);
        mod=tree[1].sum;
        int pos=0;
        boy[0].val=0;
        n=id;
        while(n--){
            if(boy[pos].val>0)  //k表剩余的人中从左起第k中出队
                k=((k-1+boy[pos].val-1)%mod+mod)%mod+1;
            else
                k=((k-1+boy[pos].val)%mod+mod)%mod+1;
            pos=update(k,1);
            mod=tree[1].sum;
        }
        printf("%s %d\n",boy[pos].name,ans[id]);
    }
    return 0;
}

 

posted @ 2013-04-23 19:33  Jack Ge  阅读(2074)  评论(0编辑  收藏  举报