HDU Largest prime factor

Largest prime factor

http://acm.hdu.edu.cn/game/entry/problem/show.php?chapterid=2&sectionid=1&problemid=5

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2728    Accepted Submission(s): 860
 
Problem Description
Everybody knows any number can be combined by the prime number. Now, your task is telling me what position of the largest prime factor. The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc. Specially, LPF(1) = 0.
 
Input
Each line will contain one integer n(0 < n < 1000000).
 
Output
Output the LPF(n).
 
Sample Input
1
2
3
4
5
 
Sample Output
0
1
2
1
3
 
Author
Wiskey
 
Source
HDU 2007-11  Programming Contest_WarmUp
 
Recommend
威士忌

 

 

#include<stdio.h>
#include<string.h>

#define N 1000000

int prime[N+5];

void getPrime(){
    memset(prime,0,sizeof(prime));
    int i,j,k=1;
    for(i=2;i<=N;i++){
        if(!prime[i]){
            for(j=1;i*j<N;j++)
                prime[i*j]=k;
            k++;
        }
    }
    prime[1]=0;
}

int main(){
    int n;
    getPrime();
    while(scanf("%d",&n)!=EOF){
        printf("%d\n",prime[n]);
    }
    return 0;
}

 

posted @ 2013-01-03 11:10  Jack Ge  阅读(354)  评论(0编辑  收藏  举报