250 消除


/*

http://oj.daimayuan.top/course/5/problem/250

桌面上有 n
 个方块,蜗蜗想把它们都消除掉。每个方块有个权值,第 i
 个方块的权值等于 ai
。每一次消除蜗蜗有两种选择:

选择一个还没有被消除的方块 i
,付出 ai
 的代价把它消除;

选择两个还没有被消除的方块 i,j (i≠j)
,付出 ai
 xor aj
 的代价把它们消除;

请问蜗蜗最少需要花费多少代价,能把 n
 个方块都消除掉?

输入格式
第一行一个整数 n
 表示方块数目。

第二行 n 
 个整数 a1,a2,...,an
。

输出格式
一行一个整数表示答案。

样例输入
3
1 4 5
样例输出
2
数据范围
对于 100%
 的数据,保证 2≤n≤20,1≤ai≤100000。
*/

#define _CRT_SECURE_NO_WARNINGS

#include <iostream>
#include <algorithm>
#include <memory.h>

using namespace std;


const int N = 25;
int a[N];
int n;
int ans;


int dp[1 << N];


bool isIn(int st, int a) {
	return st & (1 << a);
}


int main()
{
	scanf("%d",&n);
	for (int i = 0; i < n; i++) scanf("%d",&a[i]);

	memset(dp, 0x3f, sizeof dp);
	dp[(1 << n) - 1] = 0;
	for(int st = (1 << n) - 1; st >= 0; st--) {
		for (int i = 0; i < n; i++) {
			for (int j = i + 1; j < n; j++) {
				if (isIn(st, i) && isIn(st, j)) {
					int newst = st ^ (1 << i);
					newst ^= (1 << j);
					dp[newst] = min(dp[newst], dp[st] + (a[i] ^ a[j]) );
				}
			}

			if (isIn(st, i)) {
				int newst = st ^ (1 << i);
				dp[newst] = min(dp[newst], dp[st]  + a[i]);
			}
		}
	}

	printf("%d\n",dp[0]);

	return 0;
}

posted on 2024-11-07 09:53  itdef  阅读(1)  评论(0编辑  收藏  举报

导航