PAT 甲级 1001 A+B Format

地址   https://pintia.cn/problem-sets/994805342720868352/problems/994805528788582400

复制代码
Calculate a+b and output the sum in standard format -- that is, 
the digits must be separated into groups of three by commas (unless there are less than four digits). Input Specification: Each input file contains one test
case. Each case contains a pair of integers a and b where
106≤a,b≤106 ​​ . The numbers are separated by a space. Output Specification: For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format. Sample Input: -1000000 9 Sample Output: -999,991
复制代码

题目大意是 

两数相加 使用每个三个数字打印一个','的形式将其显示出来

解答

这个主要是熟悉 字符串与数字之间的转换逆转换。

模拟题,主要注意数字和字符串的转换,并且每隔三个数字就要加上一个逗号
但是逗号任意一边只有负号或者是起点 或终点则不必添加逗号(-199 199 )

复制代码
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;

int n, m;

int main()
{
    cin >> n >> m;
    int k = n + m;
    string ans;
    int flag = 0;
    if (k < 0) {flag = 1;k = abs(k);}
    else if (k == 0) {cout << 0 << endl;return 0;}

    int count = 0;
    while (k != 0) {
        int tmp = k % 10;k = k / 10;
        ans += (char)('0' + tmp);
        count++;
        if (count % 3 == 0 && k!=0) {ans += ',';}
    }
    reverse(ans.begin(),ans.end());
    if (flag) ans.insert(ans.begin(), '-');

    cout << ans << endl;
    return 0;
}

 
复制代码

 如果 添加个额外的字符串空间,将两数之和的字符串逐个的复制过来,每隔复制三个字符,添加一个','  ,

思路会更清晰一些

复制代码
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;

int n, m;

int main()
{
    cin >> n >> m;
    string tmp = to_string(n + m);
    string ans;
    int count=0;
    for(int i = tmp.size()-1;i>=0;i--){
        ans += tmp[i];
        count++;
        if(count%3==0 && i>0 && tmp[i-1] != '-'){
            ans+=',';
        }
    }
    reverse(ans.begin(),ans.end());
    cout << ans<<endl;
    return 0;
}
复制代码

 

posted on   itdef  阅读(76)  评论(0编辑  收藏  举报

编辑推荐:
· go语言实现终端里的倒计时
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
阅读排行:
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· ollama系列1:轻松3步本地部署deepseek,普通电脑可用
· 按钮权限的设计及实现
· 25岁的心里话
历史上的今天:
2017-02-07 链表 写队列和栈 练习代码

导航

< 2025年3月 >
23 24 25 26 27 28 1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31 1 2 3 4 5

统计

点击右上角即可分享
微信分享提示