poj 1273 Drainage Ditches

地址  http://poj.org/problem?id=1273

Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

网络流 解答

复制代码
// 11111111111.cpp : 此文件包含 "main" 函数。程序执行将在此处开始并结束。
//

#include <iostream>
#include <queue>

using namespace std;

/*
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10
*/
const int maxn = 220;
const int inf = 0x7f7f7f7f;

int G[maxn][maxn], flow[maxn],pre[maxn];
int n, m;
queue<int> q;

int bfs(int s, int t)
{
    while (!q.empty()) q.pop();
    memset(pre, -1, sizeof(pre));
    pre[s] = -1; flow[s] = inf;
    q.push(s);
    while (!q.empty()) {
        int p = q.front(); q.pop();
        if (p == t) break;
        for (int u = 1; u <= n; u++) {
            if (u != s && G[p][u] > 0 && pre[u] == -1) {
                pre[u] = p;
                flow[u] = min(flow[p], G[p][u]);
                q.push(u);
            }
        }
    }
    if (pre[t] == -1) return -1;
    return flow[t];
}

int EK(int s, int t)
{
    int delta = 0, tot = 0;
    while (1) {
        delta = bfs(s, t);
        if (delta == -1) break;
        int p = t;
        while (p != s) {
            G[pre[p]][p] -= delta;
            G[p][pre[p]] += delta;
            p = pre[p];
        }
        tot += delta;
    }

    return tot;
}


int main()
{
    int u, v, w;
    while (~scanf("%d%d", &m, &n)) {
        memset(G, 0, sizeof(G));
        memset(flow, 0, sizeof(flow));
        for (int i = 0; i < m; i++) {
            scanf("%d%d%d", &u, &v, &w);
            G[u][v] += w;
        }
        printf("%d\n", EK(1, n));
    }

    return 0;
}
复制代码

 

posted on   itdef  阅读(253)  评论(0编辑  收藏  举报

编辑推荐:
· go语言实现终端里的倒计时
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
阅读排行:
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· ollama系列1:轻松3步本地部署deepseek,普通电脑可用
· 按钮权限的设计及实现
· 25岁的心里话
历史上的今天:
2016-03-10 VS2015 python

导航

< 2025年3月 >
23 24 25 26 27 28 1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31 1 2 3 4 5

统计

点击右上角即可分享
微信分享提示