/ppp profile up-down script 的变量

复制代码
:local  localAddr      //本地IP
:local remoteAddr   //远程IP
:local callerId       
:local calledId
:local interfaceName  //接口名字

:set localAddr $"local-address"
:set remoteAddr $"remote-address"
:set callerId $"caller-id"
:set calledId $"called-id"
:set interfaceName [/interface get $interface name]
复制代码

 使用示例1 :添加源IP路由

复制代码
{

:local  localAddr      
:local interfaceName 
:set localAddr $"local-address"
:set interfaceName [/interface get $interface name]
:log info message="start $interfaceName"
/ip route rule set [find comment="$interfaceName"] src-address="$localAddr"
:log error message="$interfaceName====>$localAddr"

}

使用前先在/ip route rule里添加标记
{
:for i from=1 to=200 do={
/ip route rule add src-address=1.1.1.1 table="R$i" comment="pppoe-out$i"
/ip route rule set [find comment="pppoe-out$i"] src-address=[/ip add get [find interface="pppoe-out$i"] address]
}
}

 

复制代码

 

posted @   嗷嗷鹿鸣[VX|dshoub]  阅读(199)  评论(0编辑  收藏  举报
编辑推荐:
· 探究高空视频全景AR技术的实现原理
· 理解Rust引用及其生命周期标识(上)
· 浏览器原生「磁吸」效果!Anchor Positioning 锚点定位神器解析
· 没有源码,如何修改代码逻辑?
· 一个奇形怪状的面试题:Bean中的CHM要不要加volatile?
阅读排行:
· 分享4款.NET开源、免费、实用的商城系统
· 全程不用写代码,我用AI程序员写了一个飞机大战
· MongoDB 8.0这个新功能碉堡了,比商业数据库还牛
· 白话解读 Dapr 1.15:你的「微服务管家」又秀新绝活了
· 上周热点回顾(2.24-3.2)
点击右上角即可分享
微信分享提示