HDU 1042 N!

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 75324    Accepted Submission(s): 21992


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

 

Input
One N in one line, process to the end of file.
 

 

Output
For each N, output N! in one line.
 

 

Sample Input
1
2
3
 

 

Sample Output
1
2
6
 

 

Author
JGShining(极光炫影)
 
 
 
解析:大数。
 
 
import java.math.BigInteger;
import java.util.Scanner;

public class Main {
    static BigInteger fact(int n){
        BigInteger ret = BigInteger.ONE;
        for(int i = 1; i <= n; ++i){
            ret = ret.multiply(BigInteger.valueOf(i));
        }
        return ret;
    }
    public static void main(String[] args){
        Scanner in = new Scanner(System.in);
        int n;
        while(in.hasNext()){
        	n = in.nextInt();
            System.out.println(fact(n));
        }
        in.close();
    }
}

  

posted on 2016-08-19 14:17  月夜下  阅读(145)  评论(0编辑  收藏  举报

导航

"320px">