HDU 5835 Danganronpa

Danganronpa

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 406    Accepted Submission(s): 294


Problem Description
Chisa Yukizome works as a teacher in the school. She prepares many gifts, which consist of n kinds with a[i] quantities of each kind, for her students and wants to hold a class meeting. Because of the busy work, she gives her gifts to the monitor, Chiaki Nanami. Due to the strange design of the school, the students' desks are in a row. Chiaki Nanami wants to arrange gifts like this:

1. Each table will be prepared for a mysterious gift and an ordinary gift.

2. In order to reflect the Chisa Yukizome's generosity, the kinds of the ordinary gift on the adjacent table must be different.

3. There are no limits for the mysterious gift.

4. The gift must be placed continuously.

She wants to know how many students can get gifts in accordance with her idea at most (Suppose the number of students are infinite). As the most important people of her, you are easy to solve it, aren't you?
 

 

Input
The first line of input contains an integer T(T10) indicating the number of test cases.

Each case contains one integer n. The next line contains n (1n10) numbers: a1,a2,...,an(1ai100000).
 

 

Output
For each test case, output one line containing “Case #x: y” (without quotes) , where x is the test case number (starting from 1) and y is the answer of Chiaki Nanami's question.
 

 

Sample Input
1
2
3 2
 

 

Sample Output
Case #1: 2
 

 

Author
UESTC
 

 

Source
 
 
 
解析:贪心。
 
 
 
#include <cstdio>
#include <algorithm>
using namespace std;

int a[15];

int main()
{
    int t, n, cn = 0;
    scanf("%d", &t);
    while(t--){
        scanf("%d", &n);
        int sum = 0, m = 0;
        for(int i = 0; i < n; ++i){
            scanf("%d", &a[i]);
            sum += a[i];
            m = max(m, a[i]);
        }
        int res = min(sum/2, (sum-m)*2+1);
        printf("Case #%d: %d\n", ++cn, res);
    }
    return 0;
}

  

posted on 2016-08-15 16:02  月夜下  阅读(201)  评论(0编辑  收藏  举报

导航

"320px">