HDU 5761 Rower Bo

Rower Bo

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 977    Accepted Submission(s): 356
Special Judge


Problem Description
There is a river on the Cartesian coordinate system,the river is flowing along the x-axis direction.

Rower Bo is placed at (0,a) at first.He wants to get to origin (0,0) by boat.Boat speed relative to water is v1,and the speed of the water flow is v2.He will adjust the direction of v1 to origin all the time.

Your task is to calculate how much time he will use to get to origin.Your answer should be rounded to four decimal places.

If he can't arrive origin anyway,print"Infinity"(without quotation marks).
 

 

Input
There are several test cases. (no more than 1000)

For each test case,there is only one line containing three integers a,v1,v2.

0a1000v1,v2,100a,v1,v2 are integers
 

 

Output
For each test case,print a string or a real number.

If the absolute error between your answer and the standard answer is no more than 104, your solution will be accepted.
 

 

Sample Input
2 3 3
2 4 3
 

 

Sample Output
Infinity
1.1428571429
 

 

Source
 
 
 
解析:
 
设船到原点的距离是r,可得方程如下:

积分的上下界都很明确,进行定积分得:

得到结果如下:

 当a == 0时,结果T显然为0。当v1>v2时,船能到达目的地,结果就是上面推导的结果;否则船不能到达目的地。
 
 
 
 
#include <bits/stdc++.h>

int main()
{
    double a, v1, v2;
    while(~scanf("%lf%lf%lf", &a, &v1, &v2)){
        if(a == 0){
            printf("0\n");
            continue;
        }
        if(v1>v2)
            printf("%f\n", a*v1/(v1*v1-v2*v2));
        else
            printf("Infinity\n");
    }
    return 0;
}

 

posted on 2016-07-27 16:11  月夜下  阅读(156)  评论(0编辑  收藏  举报

导航

"320px">