HDU 5734 Acperience

Acperience

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 220    Accepted Submission(s): 119


Problem Description
Deep neural networks (DNN) have shown significant improvements in several application domains including computer vision and speech recognition. In computer vision, a particular type of DNN, known as Convolutional Neural Networks (CNN), have demonstrated state-of-the-art results in object recognition and detection.

Convolutional neural networks show reliable results on object recognition and detection that are useful in real world applications. Concurrent to the recent progress in recognition, interesting advancements have been happening in virtual reality (VR by Oculus), augmented reality (AR by HoloLens), and smart wearable devices. Putting these two pieces together, we argue that it is the right time to equip smart portable devices with the power of state-of-the-art recognition systems. However, CNN-based recognition systems need large amounts of memory and computational power. While they perform well on expensive, GPU-based machines, they are often unsuitable for smaller devices like cell phones and embedded electronics.

In order to simplify the networks, Professor Zhang tries to introduce simple, efficient, and accurate approximations to CNNs by binarizing the weights. Professor Zhang needs your help.

More specifically, you are given a weighted vector W = (w1,w2,...,wn). Professor Zhang would like to find a binary vector B = (b1,b2,...,bn)(bi∈{+1,-1}) and a scaling factor α≥0 in such a manner that ||W-αB|| 2 is minimum.

Note that ||.|| denotes the Euclidean norm (i.e.||X|| = √ x12+...+xn2, where X(x1,x2,...,xn).

 

 

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains an integers n (1≤n≤100000) -- the length of the vector. The next line contains n integers: w1,w2,...,wn (−10000≤wi≤10000).
 

 

Output
For each test case, output the minimum value of ||W-αB|| 2 as an irreducible fraction "p/q" where re integers, q>0.
 

 

Sample Input
3
4
1 2 3 4
4
2 2 2 2
5
5 6 2 3 4
 

 

Sample Output
5/1
0/1
10/1
 

 

Author
zimpha
 

 

Source
 
 
 
解析:
i=1n​​wi2​​n1​​(i=1n​​wi​​)2​​
 
 
 

 

#include <bits/stdc++.h>

typedef long long ll;

ll gcd(ll a, ll b)
{
    return b == 0 ? a : gcd(b, a%b);
}

int main()
{
    int T, n;
    scanf("%d", &T);
    while(T--){
        scanf("%d", &n);
        ll w1 = 0, w2 = 0;
        for(int i = 0, wi; i < n; ++i){
            scanf("%d", &wi);
            w1 += wi*wi;
            w2 += abs(wi);
        }
        ll a = w1*n-w2*w2, b = n;
        ll g = gcd(a, b);
        printf("%I64d/%I64d\n", a/g, b/g);
    }
    return 0;
}

  

posted on 2016-07-21 21:52  月夜下  阅读(153)  评论(0编辑  收藏  举报

导航

"320px">