P1948 [USACO08JAN]Telephone Lines S
[USACO08JAN]Telephone Lines S
题目描述
Farmer John wants to set up a telephone line at his farm. Unfortunately, the phone company is uncooperative, so he needs to pay for some of the cables required to connect his farm to the phone system.
There are N (1 ≤ N ≤ 1,000) forlorn telephone poles conveniently numbered 1..N that are scattered around Farmer John's property; no cables connect any them. A total of P (1 ≤ P ≤ 10,000) pairs of poles can be connected by a cable; the rest are too far apart.
The i-th cable can connect the two distinct poles Ai and Bi, with length Li (1 ≤ Li ≤ 1,000,000) units if used. The input data set never names any {Ai, Bi} pair more than once. Pole 1 is already connected to the phone system, and pole N is at the farm. Poles 1 and N need to be connected by a path of cables; the rest of the poles might be used or might not be used.
As it turns out, the phone company is willing to provide Farmer John with K (0 ≤ K < N) lengths of cable for free. Beyond that he will have to pay a price equal to the length of the longest remaining cable he requires (each pair of poles is connected with a separate cable), or 0 if he does not need any additional cables.
Determine the minimum amount that Farmer John must pay.
多年以后,笨笨长大了,成为了电话线布置师。由于地震使得某市的电话线全部损坏,笨笨是负责接到震中市的负责人。该市周围分布着
第i对电线杆的两个端点分别是
电信公司决定支援灾区免费为此市连接
请你计算一下,将电话线引导震中市最少需要在电话线上花多少钱?
输入格式
输入文件的第一行包含三个数字
第二行到第
输出格式
一个整数,表示该项工程的最小支出,如果不可能完成则输出 -1
。
样例 #1
样例输入 #1
5 7 1
1 2 5
3 1 4
2 4 8
3 2 3
5 2 9
3 4 7
4 5 6
样例输出 #1
4
思路:
因为要求最短的距离中边的最大值,所以考虑用二分,首先我们二分边权最大值,把边权大于最大边权的边免费,最后如果免费的边数小于等于
这里要注意如果不连通的话,是会取到最大值的,所以我们把二分上限加
代码
#include <cstdio>
#include <cstring>
#include <deque>
using namespace std;
const int N = 1010,M = 20010;
int n,m,k;
int h[N],e[M],ne[M],w[M],idx = 0;
int dist[N];
bool st[N];
void add (int a,int b,int c) {
e[idx] = b;
w[idx] = c;
ne[idx] = h[a];
h[a] = idx++;
}
bool check (int x) {
memset (dist,0x3f,sizeof (dist));
dist[1] = 0;
st[1] = true;
deque <int> q;
q.push_back (1);
int cnt = 0;
while (q.size ()) {
int t = q.front ();
q.pop_front ();
for (int i = h[t];~i;i = ne[i]) {
int j = e[i],v = w[i] > x;
if (dist[j] > dist[t]+v || !st[j]) {
dist[j] = dist[t]+v;
st[j] = true;
if (v) q.push_back (j);
else q.push_front (j);
}
}
}
return dist[n] <= k;
}
int main () {
memset (h,-1,sizeof (h));
scanf ("%d%d%d",&n,&m,&k);
int maxw = 0;
while (m--) {
int a,b,c;
scanf ("%d%d%d",&a,&b,&c);
add (a,b,c),add (b,a,c);
maxw = max (maxw,c);
}
int l = 1,r = maxw+1;
while (l < r) {
int mid = l + r >> 1;
if (check (mid)) r = mid;
else l = mid + 1;
}
if (l == maxw+1) printf ("-1");
else printf ("%d\n",l);
return 0;
}
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· ollama系列01:轻松3步本地部署deepseek,普通电脑可用
· 25岁的心里话
· 按钮权限的设计及实现