cigarettes

cigarettes

描述

Tom has many cigarettes. We hypothesized that he has n cigarettes and smokes them

one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette.  Now,do you know how many cigarettes can Tom has?

 
输入
First input is a single line,it's n and stands for there are n testdata.then there are n lines ,each line contains two integer numbers giving the values of n and k.
输出
For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.
样例输入
3
4 3
10 3
100 5
样例输出
5
14
124

 
#include<iostream>
using namespace std;
int main()
{
int n;
cin>>n;
while(n--){
int m,k;
cin>>m>>k;
int sum=m;
while(m/k){
sum=sum+m/k;
m=m/k+m%k;
}
cout<<sum<<endl;
}
return 0;
}        

 

posted @ 2014-11-02 16:38  -渔人码头-  阅读(306)  评论(0编辑  收藏  举报