hdoj3351-stack



Problem Description
I’m out of stories. For years I’ve been writing stories, some rather silly, just to make simple problems look difficult and complex problems look easy. But, alas, not for this one.
You’re given a non empty string made in its entirety from opening and closing braces. Your task is to find the minimum number of “operations” needed to make the string stable. The definition for being stable is as follows:
1. An empty string is stable.
2. If S is stable, then {S} is also stable.
3. If S and T are both stable, then ST (the concatenation of the two) is also stable.
All of these strings are stable: {}, {}{}, and {{}{}}; But none of these: }{, {{}{, nor {}{.
The only operation allowed on the string is to replace an opening brace with a closing brace, or visa-versa.
 

 

Input
Your program will be tested on one or more data sets. Each data set is described on a single line. The line is a non-empty string of opening and closing braces and nothing else. No string has more than 2000 braces. All sequences are of even length.
The last line of the input is made of one or more ’-’ (minus signs.)

 

 

Output
For each test case, print the following line:
k. N
Where k is the test case number (starting at one,) and N is the minimum number of operations needed to convert the given string into a balanced one.
Note: There is a blank space before N.
 

 

Sample Input
}{ {}{}{} {{{} ---
 

 

Sample Output
1. 2 2. 0 3. 1
思路:
一开始设置了两个变量,l和r分别代表左括号和右括号,后来发现和stack相关的操作只用设置一个变量即可,可是说是用来记录stack高度的也可以说是用来记录'{'值的。这样不仅更方便灵活,而且(我想不到合适的词语来描述。。)更容易激发灵感!

#include <iostream>
#include <string>
using namespace std;

int main()
{
    string ss;
    int shift,l,K = 0;
    while(cin>>ss) {
        if(ss[0] == '-')
            break;
        l = 0;
        shift = 0;
        for(int i = 0;i < ss.length();i++) {
            if(ss[i] == '{') 
                l++;
            else if(l) 
                l--;
            else {
                l++;
                shift++;
            }
        }
        cout<<++K<<". "<<l/2+shift<<endl;
    }
    return 0;
}

 

posted @ 2016-11-19 08:06  Miller_S  阅读(433)  评论(0编辑  收藏  举报