docker安装OP

docker pull xuanaimai/onecloud:21-03-05
复制代码
开启网卡混杂模式
ip link set eth0 promisc on
复制代码

创建网络
docker network create -d macvlan --subnet=192.168.102.0/24 --gateway=192.168.102.1 -o parent=eth0 macnet
复制代码
虚拟网络名称为 macnet,驱动为 macvlan 模式

将 subnet 10.10.10.0 修改为你自己主路由的网段

将 geteway 10.10.10.1 修改为你自己的主路由网关

运行容器
docker run --restart always --name openwrt -d --network macnet --privileged xuanaimai/onecloud:21-03-05 /sbin/init
复制代码
进入容器
docker exec -it openwrt /bin/bash
复制代码
修改网络
vi /etc/config/network
复制代码
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
option ifname 'eth0'
option _orig_ifname 'eth0'
option _orig_bridge 'true'
option proto 'static'
option ipaddr '10.10.10.11' # 填写创建容器时的IP
option netmask '255.255.255.0'
option gateway '10.10.10.1' # 修改为你自己主路由的IP
option dns '10.10.10.1' # DNS 可填主路由IP 也可填公共DNS
复制代码
我们只需要更改 Lan 口设置:
config interface 'lan'
option ifname 'eth0'
option _orig_ifname 'eth0'
option _orig_bridge 'true'
option proto 'static'
option ipaddr '192.168.123.2' # 填写创建容器时的IP
option netmask '255.255.255.0'
option gateway '192.168.123.1' # 修改为你自己主路由的IP
option dns '192.168.123.1' # DNS 可填主路由IP 也可填公共DNS
复制代码
修改完成后

重启容器网络服务

/etc/init.d/network restart

退出容器

exit
复制代码
注意:以下必须操作,否则经过旁路由的设备没网
容器 OpenWrt 的相关设置
接口
网络 > 接口 > 修改
忽略此接口 (勾选)> 保存&应用

防火墙
网络 > 防火墙
基本设置 > 启用FullCone-NAT(勾选) > 转发 - 接受 > 保存&应用
(以上搬运于https://github.com/233Bazinga/OneCloud)
详细设置可参考 https://mlapp.cn/376.html

posted @ 2023-03-26 08:05  imagecc  阅读(193)  评论(0编辑  收藏  举报