HDU 1021:Fibonacci Again

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 48576    Accepted Submission(s): 23040


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
0 1 2 3 4 5
 

Sample Output
no no yes no no no
 

Author
Leojay
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1019 1108 1049 1013 1170 
 

你  离  开  了  ,  我  的  世  界  里  只  剩  下  雨  。  。  。

#include <stdio.h>
#include <stdlib.h>
int main()
{
    int a;
    while(~scanf("%d",&a))
    {
        if(a%8==2||a%8==6)
            printf("yes\n");
        else printf("no\n");
    }
    return 0;
}


posted @ 2016-01-30 09:25  小坏蛋_千千  阅读(111)  评论(0编辑  收藏  举报