HDU 1009:FatMouse' Trade

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 60163    Accepted Submission(s): 20217


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
13.333 31.500
 

Author
CHEN, Yue
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1050 1051 1003 2037 1052 
 

你  离  开  了  ,  我  的  世  界  里  只  剩  下  雨  。  。  。

#include <stdio.h>
#include <algorithm>
using namespace std;
struct Node
{
    double j,f,p;
} node[10000];
int cmp(Node x,Node y)
{
    return x.p>y.p;
}
int main()
{
    int m,n;
    while(~scanf("%d%d",&n,&m) && (m!=-1 || n!=-1))
    {
        double sum = 0;
        int i;
        for(i = 0; i<m; i++)
        {
            scanf("%lf%lf",&node[i].j,&node[i].f);
            node[i].p = node[i].j/node[i].f;
        }
        sort(node,node+m,cmp);
        for(i = 0; i<m; i++)
        {
            if(n>node[i].f)
            {
                sum+=node[i].j;
                n-=node[i].f;
            }
            else
            {
                sum+=node[i].p*n;
                break;
            }
        }
        printf("%.3lf\n",sum);
    }
    return 0;
}


posted @ 2016-01-30 09:31  小坏蛋_千千  阅读(164)  评论(0编辑  收藏  举报