POJ 1663:Number Steps

Number Steps
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 13758   Accepted: 7430

Description

Starting from point (0,0) on a plane, we have written all non-negative integers 0,1,2, ... as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively and this pattern has continued. 

You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0...5000.

Input

The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.

Output

For each point in the input, write the number written at that point or write No Number if there is none.

Sample Input

3
4 2
6 6
3 4

Sample Output

6
12
No Number

Source

你  离  开  了  ,  我  的  世  界  里  只  剩  下  雨  。  。  。

#include<iostream>
using namespace std;
int main()
{
    int n;
    cin>>n;
    while(n--)
    {
        int a,b;
        cin>>a>>b;
        if(a==b||a-b==2)
        {
            if(a==b)
            {
                if(a&1)cout<<2*a-1<<endl;
                else cout<<2*a<<endl;
            }
            else
            {
                if(b&1)cout<<2*a-3<<endl;
                else cout<<2*a-2<<endl;
            }
        }
        else cout<<"No Number"<<endl;
    }
    return 0;
}

posted @ 2016-02-01 21:00  小坏蛋_千千  阅读(202)  评论(0编辑  收藏  举报