POJ 1065:Wooden Sticks

Wooden Sticks
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 20391   Accepted: 8611

Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 
(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup. 
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1 

Sample Output

2
1
3

Source

迷失在幽谷中的鸟儿,独自飞翔在这偌大的天地间,却不知自己该飞往何方……

#include<iostream>  
#include<string.h>  
#include<algorithm>  
using namespace std;  
struct mood  
{  
    int w;  
    int l;  
} d[5005];  
bool cmp(mood a,mood b)  
{  
    if(a.l==b.l)  
        return a.w<b.w;  
    return a.l<b.l;  
}  
int k[5005];  
int main()  
{  
    int n;  
    cin>>n;  
    while(n--)  
    {  
        int m;  
        cin>>m;  
        for(int i=0; i<m; i++)  
            cin>>d[i].l>>d[i].w;  
        sort(d,d+m,cmp);  
        memset(k,-1,sizeof(k));  
        int flag=0;  
        for(int i=0; i<m; i++)  
            for(int j=0; j<=m; j++)  
                if(d[i].w>=k[j])  
                {  
                    k[j]=d[i].w;  
                    if(j+1>flag)flag=j+1;  
                    break;  
                }  
        cout<<flag<<endl;  
    }  
    return 0;  
}  


posted @ 2016-02-04 11:11  小坏蛋_千千  阅读(216)  评论(0编辑  收藏  举报