HDU 1159:Common Subsequence

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30952    Accepted Submission(s): 14010


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 

Sample Input
abcfbc abfcab programming contest abcd mnp
 

Sample Output
4 2 0
 

Source
 

Recommend
Ignatius   |   We have carefully selected several similar problems for you:  1087 1176 1003 1058 1069 
 

迷失在幽谷中的鸟儿,独自飞翔在这偌大的天地间,却不知自己该飞往何方……

#include <stdio.h>  
#include <string.h>  
#include <algorithm>  
using namespace std;  
char s1[1000],s2[1000];  
int dp[1000][1000];  
int len1,len2;  
void LCS()  
{  
    int i,j;  
    memset(dp,0,sizeof(dp));  
    for(i = 1; i<=len1; i++)  
    {  
        for(j = 1; j<=len2; j++)  
        {  
            if(s1[i-1] == s2[j-1])  
                dp[i][j] = dp[i-1][j-1]+1;  
            else  
                dp[i][j] = max(dp[i-1][j],dp[i][j-1]);  
        }  
    }  
}  
int main()  
{  
    while(~scanf("%s%s",s1,s2))  
    {  
        len1 = strlen(s1);  
        len2 = strlen(s2);  
        LCS();  
        printf("%d\n",dp[len1][len2]);  
    }  
    return 0;  
}  


posted @ 2016-02-17 12:37  小坏蛋_千千  阅读(207)  评论(0编辑  收藏  举报