数据结构 11-散列2 Hashing (25 分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (104​​) and N (MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15
 

Sample Output:

0 1 4 -

 

 

有被自己蠢到, 题目给出的输入是第一行 "MSize N"  MSize是用户自定义最大表长, 如果表长度不是素数要求继续向后探寻下一个素数, N是下一行输入的数字个数,  没看懂题以为第一个数是N... debug半天没看出来哪错 ,蠢到家了

 

题目要求使用 Quadratic probing 平方探测法解决冲突,  在冲突位置 index 的基础上, 继续探测 newindex = index+ i^2 的地址是否可用, 本题只用探测i递增的地址

 

 

 

#include <iostream>
#include <vector>
#include <algorithm>
#include <string>
#include <math.h>
using namespace std;

bool isPrimeNum(int n){
    if(n<=1){
        return false;
    }
    for(int i=2;i*i<=n;i++){
        if(n%i==0){
            return false;
        }
    }
    return true;
}

int getNextPrime(int n){
    int i{0};
    if(n==1||n%2==0)n++;
    for(i=n;;i+=2){
        if(isPrimeNum(i)){
            break;
        }
    }
    return i;
}

int main(){
    int n,t,temp;
    cin >> t >> n;
    if(!isPrimeNum(t)){//如果t不是素数, 取下一个素数
        t=getNextPrime(t);
    }
    vector<int> pos(0);
    vector<int> table(t,0);
    for(int i=0;i<n;i++){
        cin >> temp;
        int index=temp%t;
        if(table[index]==0){
            table[index]=1;
            pos.push_back(index);
        }else{
            int j,newindex;
            for(j=1;j<t;j++){
                newindex=(index+j*j)%t;
                if(!table[newindex]){
                    table[newindex]=1;
                    break;
                }
            }
            if(j>=t){
                pos.push_back(-1);
            }else{
                pos.push_back(newindex);
            }
        }
    }
    cout << pos.front();
    for(int i=1;i<pos.size();i++){
        cout << " ";
        if(pos[i]!=-1){
            cout << pos[i];
        }else{
            cout << "-";
        }
       
    }
    cout <<endl;
    return 0;
}

 

posted @ 2021-05-26 21:31  keiiha  阅读(69)  评论(0编辑  收藏  举报