数据结构 11-散列1 电话聊天狂人 (25 分)

给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。

输入格式:

输入首先给出正整数N(105​​),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。

输出格式:

在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。

输入样例:

4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832
 

输出样例:

13588625832 3

 

 

 

#include <iostream>
#include <vector>
#include <algorithm>
#include <unordered_map>
using namespace std;
class telnum{
public:
    long id;
    int times;
    int hashcode;
    telnum()=default;
    telnum(long i,int t):id{i},times{t}{};
};
bool compare(telnum* l,telnum* r){
    if(l->times==r->times){
        return l->id<r->id;
    }else{
        return l->times>r->times;
    }
}
int main(){
    int n;
    int temp,count{1};
    unordered_map<long,telnum*> hashmap;
    vector<telnum*> tels;
    cin >> n;
    long a,b;
    for(int i=0;i<n;i++){
        scanf("%ld %ld",&a,&b);
        if(hashmap.find(a)==hashmap.end()){
            hashmap[a]=new telnum{a,0};
        }
        if(hashmap.find(b)==hashmap.end()){
            hashmap[b]=new telnum{b,0};
        }
        hashmap[a]->times++;
        hashmap[b]->times++;
    }
    for(auto it=hashmap.begin();it!=hashmap.end();it++){
        tels.push_back(it->second);
    }
    sort(tels.begin(), tels.end(), compare);
    cout << tels.front()->id;
    for(int i=1;i<tels.size();i++){
        if(tels[i]->times==tels[i-1]->times){
            count++;
        }else{
            break;
        }
    }
    cout <<" "<< tels.front()->times;
    if(count>1)cout <<" "<<count<<endl;
    return 0;
}

 

posted @ 2021-05-26 15:15  keiiha  阅读(59)  评论(0编辑  收藏  举报