数据结构 05-树8 File Transfer (25 分)

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains N (2N104​​), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

I c1 c2  
 

where I stands for inputting a connection between c1 and c2; or

C c1 c2    
 

where C stands for checking if it is possible to transfer files between c1 and c2; or

S
 

where S stands for stopping this case. 

Output Specification:

For each C case, print in one line the word "yes" or "no" if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line "The network is connected." if there is a path between any pair of computers; or "There are k components." where k is the number of connected components in this network.

Sample Input 1:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S
 

Sample Output 1:

no
no
yes
There are 2 components.
 

Sample Input 2:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S
 

Sample Output 2:

no
no
yes
yes
The network is connected.

 

并查集的查找与合并

参考文章 https://zhuanlan.zhihu.com/p/93647900/

 

#include <iostream>
#include <vector>
using namespace std;
class unionFindSet{
public:
    vector<int> ufs;
    vector<int> rank;
    unionFindSet()=default;
    unionFindSet(int n){
        ufs=vector<int>(n+1);
        rank=vector<int>(n+1,1);
        for(int i=0;i<n+1;i++){
            ufs[i]=i;
        }
    };
    int find(int x){
        return ufs[x]==x?x:ufs[x]=find(ufs[x]);
    }
    void merge(int i,int j){
        int x=find(i),y=find(j);
        if(rank[x]<=rank[y]){
            ufs[x]=y;
        }else{
            ufs[y]=x;
        }
        if(rank[x]==rank[y]&&x!=y){
            rank[y]++;
        }
    }
    void components(){
        int count{0};
        for(int i=1;i<ufs.size();i++){
            if(ufs[i]==i){
                count++;
            }
        }
        if(count==1){
            cout <<"The network is connected."<<endl;
        }else{
            cout <<"There are "<< count <<" components."<<endl;
        }
    }
    void judge(){
        int x,y;
        string str;
        cin >> str;
        while(str!="S"){
            cin >> x >> y;
            if(str=="I"){
                merge(find(x), find(y));
            }
            if(str=="C"){
                if(find(x)==find(y)){
                    cout << "yes"<<endl;
                }else{
                    cout << "no"<<endl;
                }
            }
            cin >> str;
        }
    }
};
int main(){
    int n;
    cin >> n;
    unionFindSet ufs{n};
    ufs.judge();
    ufs.components();
    return 0;
}

 

posted @ 2021-05-19 21:28  keiiha  阅读(82)  评论(0编辑  收藏  举报