数据结构 03-树3 Tree Traversals Again (25 分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1 

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
 

Sample Output:

3 4 2 6 5 1

 

 

给定先序遍历和中序遍历生成二叉树 输出后续遍历的结果

#include <iostream>
#include <vector>
#include <map>
using namespace std;
class tnode{
public:
    int data;
    tnode* left{nullptr};
    tnode* right{nullptr};
    tnode()=default;
    tnode(int d):data{d}{
    }
};
class tree{
public:
    tnode* root;
    int height;
    tree(){
        tnode* node=new tnode;
        root=node;
    }
};
void generateTree(tree &t){
    //根据给定的先序和中序遍历
    //建树
    int n,temp;
    vector<tnode*> stack;
    string str;
    cin >>n;
    cin >> str >> temp;
    tnode* curNode=t.root;
    curNode->data=temp;
    curNode->left=nullptr;
    curNode->right=nullptr;
    stack.push_back(curNode);
    for(int i=0;i<2*n;i++){
        cin >> str;
        if(str=="Pop"){//
            curNode=stack.back();
            stack.pop_back();
        }else{
            cin >> temp;
            tnode* newNode=new tnode{temp};
            if(!curNode->left){
                curNode->left=newNode;
                curNode=curNode->left;
            }else if(!curNode->right){
                curNode->right=newNode;
                curNode=curNode->right;
            }
            stack.push_back(newNode);
        }
    }
}
void postOrderTraversal(tnode* p,int rootData){
    if(p){
        if(p->left){
            postOrderTraversal(p->left,rootData);
        }
        if(p->right){
            postOrderTraversal(p->right,rootData);
        }
        cout << p->data;
        if(rootData!=p->data){
            cout<<" ";
        }
    }
}
int main(){
    tree t;
    generateTree(t);
    postOrderTraversal(t.root,t.root->data);
    return 0;
}

 

posted @ 2021-05-18 00:23  keiiha  阅读(61)  评论(0编辑  收藏  举报