数据结构 03-树1 树的同构 (25 分)

 

给定两棵树T1和T2。如果T1可以通过若干次左右孩子互换就变成T2,则我们称两棵树是“同构”的。例如图1给出的两棵树就是同构的,因为我们把其中一棵树的结点A、B、G的左右孩子互换后,就得到另外一棵树。而图2就不是同构的。


图1

图2

 

现给定两棵树,请你判断它们是否是同构的。

输入格式:

输入给出2棵二叉树树的信息。对于每棵树,首先在一行中给出一个非负整数N (10),即该树的结点数(此时假设结点从0到N1编号);随后N行,第i行对应编号第i个结点,给出该结点中存储的1个英文大写字母、其左孩子结点的编号、右孩子结点的编号。如果孩子结点为空,则在相应位置上给出“-”。给出的数据间用一个空格分隔。注意:题目保证每个结点中存储的字母是不同的。

输出格式:

如果两棵树是同构的,输出“Yes”,否则输出“No”。

输入样例1(对应图1):

8
A 1 2
B 3 4
C 5 -
D - -
E 6 -
G 7 -
F - -
H - -
8
G - 4
B 7 6
F - -
A 5 1
H - -
C 0 -
D - -
E 2 -
 

输出样例1:

Yes
 

输入样例2(对应图2):

8
B 5 7
F - -
A 0 3
C 6 -
H - -
D - -
G 4 -
E 1 -
8
D 6 -
B 5 -
E - -
H - -
C 0 2
G - 3
F - -
A 1 4
 

输出样例2:

No

 

 

 

#include <iostream>
#include <vector>
#include <map>
#include <set>
using namespace std;
class tnode {
public:
    string data;
    int left{-1};
    int right{-1};
    tnode()=default;    tnode(string d):data{d},left{-1},right{-1}{};
};
int initTree(map<int,tnode> &t){
    string templ,tempr,data;
    int l,r,n,rootIndex;
    cin >> n;
    vector<int> leafList(n,0);
    for(int i=0;i<n;i++){
        cin >> data >> templ >> tempr;
        t[i]=tnode{data};
        if(templ!="-"){
            l=stoi(templ);
            t[i].left=l;
            leafList[l]=1;
        }
        if(tempr!="-"){
            r=stoi(tempr);
            t[i].right=r;
            leafList[r]=1;
        }
    }
    for(int i=0;i<leafList.size();i++){
        if(leafList[i]==0){
            rootIndex=i;
            break;
        }
    }
    return rootIndex;
}
bool isIsomorphicBinaryTree(map<int,tnode> &t1,map<int,tnode> &t2,int root1,int root2){
    if(root1==-1&&root2==-1){
        return true;
    }else if((root1!=-1&&root2==-1)||(root1==-1&&root2!=-1)||t1[root1].data!=t2[root2].data){
        return false;
    }
    if(t1[root1].left==-1&&t2[root2].left==-1){
        return isIsomorphicBinaryTree(t1,t2,t1[root1].right, t2[root2].right);
    }
    if((t1[root1].left!=-1&&t2[root2].left!=-1&&t1[t1[root1].left].data==t2[t2[root2].left].data)){
        return isIsomorphicBinaryTree(t1,t2,t1[root1].right, t2[root2].right);
    }else{
        return isIsomorphicBinaryTree(t1,t2,t1[root1].left, t2[root2].right)&&isIsomorphicBinaryTree(t1,t2,t1[root1].right, t2[root2].left);
    }
}
int main(){
    int t1root,t2root;
    map<int,tnode> t1;
    map<int,tnode> t2;
    t1root=initTree(t1);
    t2root=initTree(t2);
    if(isIsomorphicBinaryTree(t1,t2,t1root,t2root)){
        cout << "Yes"<<endl;
    }else{
        cout << "No"<<endl;
    }
    return 0;
}

 

posted @ 2021-05-17 17:17  keiiha  阅读(59)  评论(0编辑  收藏  举报