The Suspects

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

这是很典型的并查集,代码如下:
#include<iostream>
using namespace std;
int father[30001],num[30001];  //num数记录该集合成员的个数 


void make_father(int n)  
 {
    int i;
    for(i=0;i<n;i++)
    {
  	    father[i]=i;
		 num[i]=1;
    }
}
int find (int x)
{
	if (x!=father[x])           //用递归实现父亲节点的查找 
	    father[x]=find(father[x]);
	return father[x];
}
 
int make(int a,int b)
{
	if (a==b)       //分情况进行合并 
	{
	    return 0;
	}
	if (num[a]<=num[b])
	{
		father[a]=b;
		num[b]+=num[a];
	}
	else
	{
		father[b]=a;
		num[a]+=num[b];
	}
}


int main()
{
	int m,n,i,j,k,a,b,fa,fb;
	while(cin>>n>>m&&n||m)
	{
		make_father(n);
		for (i=0;i<m;i++)
		{
			cin>>k;
			cin>>a;
			for (j=1;j<k;j++)
			{
				cin>>b;
				fa=find(a);
				fb=find(b);
				make(fa,fb);
			}
		}
		cout<<num[find(0)]<<endl;
	}
}

posted @ 2014-03-29 18:45  浪子小黄人  阅读(158)  评论(0编辑  收藏  举报