HDU ACM 2456 Aggressive cows

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

代码如下:
#include<iostream>
#include<algorithm>
using namespace std;


long N,C,a[100010];


bool search(long x)
{
long i,n=a[1],m=1;
for (i=2;i<=N;i++)
{
if (a[i]-n>=x)
{
   n=a[i];
m++;
}
if (m>=C)
   return true;
}
return false;
}


int main()
{
while(cin>>N>>C)
{
for(int i=1; i<=N; i++)  
            cin>>a[i];  
        sort(a+1,a+1+N);  //   高效的排序方法(升序)
        int l=0,r=a[N],mid;  
        while(l+1<r)  
        {  
            mid=(l+r)/2;  
            if(search(mid))  
                l=mid;  
            else  
                r=mid;  
        }  
        cout<<l<<endl;  
}
return 0;
}


posted @ 2014-04-01 23:31  浪子小黄人  阅读(210)  评论(0编辑  收藏  举报