poj 1827 A Bunch Of Monsters 贪心

A Bunch Of Monsters
Time Limit: 2000MS   Memory Limit: 30000K
Total Submissions: 944   Accepted: 357

Description

Background 
Jim is a brave explorer. One day, he set out for his next destination, a mysterious hill. When he arrived at the foot of the hill, he was told that there were a bunch of monsters living in that hill, and was dissuaded from continuing his trip by the residents near the hill. Nevertheless, our Jim was so brave that he would never think of giving up his exploration. 
The monsters do exist! When he got into that hill, he was caught by a bunch of fearful monsters. 
Fortunately, the monsters didn’t plan to kill him or eat him for they were planning a big party. They wanted to invite Jim, a clever human being, to their party, in order to let human beings know that the monsters also have wonderful parties. 
Problem 
At the end of the party, the monsters promised that, after the last game, they would set Jim free. The game is described as follow: 
1. There are a great many boxes of treasure, which are numbered from 1 to X. One box has the only one number; one number can only appear on one box. Furthermore, we can assume that X is INFINITY, because the monsters have got a lot of treasure from the men they caught. 
2. There are N monsters in this game. Each picks up a card randomly. After that, he / she (it?) opens it, getting a positive integer number d[i], and cannot change it or pick up another card again. The range of d[i] is from 1 to M. If the i-th monster get the number d[i], he can only get the treasure box numbered equal to or less than d[i]. What’s more, one box only can be distributed to one monster; one monster can only get one box. 
3. Of course, there are many ways to distribute the boxes to the monsters when N monsters get their numbers; and not every monster can get a box in many cases. Jim has the right to make the arrangement; however, he also knows that the monsters that don’t get the boxes will also punish him. 
Jim knows the strength of the N monsters. The i-th one has the strength s[i]. We call the sum of strength s[i] of all the monsters that don’t get the boxes --- the DAMAGE to Jim. Your task is to help Jim find out the minimum DAMAGE to him. 

Input

The input consists of several test cases. In the first line of each test case, there are two positive integers N and M (1<=N<=50000, 1<=M<=50000), indicating the number of monsters and the range of numbers the monsters possibly get on the cards. Then there are N integers d[i] (1<=d[i]<=M) in the following lines, which are the numbers those monsters got. And in the rest lines of one test case, there are other N positive integers s[i] (1<=s[i]<=20000), indicating the strength of each monsters. The test case starting with 2 zeros is the final test case and has no output.

Output

For each test case, print your answer, the minimum DAMAGE, in one line without any redundant spaces.

Sample Input

1 1
1
1
7 7
6 4 4 2 3 4 3
10 70 20 60 30 50 40
0 0

Sample Output

0
50

Source

按照怪兽的伤害从大到小排序进行贪心:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1005
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

struct str
{
    int num,val;
};

str s[500010];
int visit[500010];

int cmp(const str a,const str b)
{
    return a.val>b.val;
}

int main()
{
    int i,j,n,m;
    while (scanf("%d%d",&n,&m)&&n&&m)
    {
        memset(visit,0,sizeof(visit));
        for (i=1;i<=n;i++)
            scanf("%d",&s[i].num);
        for (i=1;i<=n;i++)
            scanf("%d",&s[i].val);
        sort(s+1,s+n+1,cmp);
        int sum=0;
        for (i=1;i<=n;i++)
        {
            for (j=s[i].num;j>0;j--)
            {
                if (!visit[j])
                {
                    visit[j]=1;
                    break;
                }
            }
            if (j==0)
                sum+=s[i].val;
        }
        printf("%d\n",sum);
    }
    return 0;
}


posted @ 2014-08-08 16:47  浪子小黄人  阅读(225)  评论(0编辑  收藏  举报