Matrix Chain Multiplication (UVa 442)

 Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices.Since matrix multiplication is associative, the order in which multiplications are performed isarbitrary. However, the number of elementary multiplications needed strongly depends on theevaluation order you choose.

For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix.There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).

The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed fora given evaluation strategy.

Input Specification

Input consists of two parts: a list of matrices and a list of expressions.

The first line of the input file contains one integer n ( tex2html_wrap_inline28 ), representing the number ofmatrices in the first part. The next n lines each contain one capital letter, specifying the name of thematrix, and two integers, specifying the number of rows and columns of the matrix.

The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

Output Specification

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125
本题比较基础,可以用一个栈来完成:遇到字母时入栈,遇到右括号时出栈计算,然后将结果入栈。
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1005
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

struct st
{
    int a,b;
    st(int a=0,int b=0):a(a),b(b){}
};

stack<st>S;
int M[30],N[30];
int n;

int main()
{
    int i,j;
    char ch[3];
    char str[10010];
    scanf("%d",&n);
    for (i=0;i<n;i++)
    {
        scanf("%s",ch);
        scanf("%d%d",&M[ch[0]-'A'],&N[ch[0]-'A']);
    }
    while (~scanf("%s",str))
    {
        int len=strlen(str);
        bool No=false;
        int sum=0;
        for (i=0;i<len;i++)
        {
            if (isalpha(str[i]))
            {
                S.push(st(M[ str[i]-'A' ],N[ str[i]-'A' ]));
            }
            else if (str[i]==')')
            {
                st y=S.top();
                S.pop();
                st x=S.top();
                S.pop();
                if (x.b!=y.a)
                {
                    No=true;
                    break;
                }
                sum+=x.a*x.b*y.b;
                S.push(st(x.a,y.b));
            }
        }
        if (No)
            printf("error\n");
        else
            printf("%d\n",sum);
    }
    return 0;
}


posted @ 2014-09-12 23:11  浪子小黄人  阅读(182)  评论(0编辑  收藏  举报