All in All UVA - 10340

You have devised a new encryption technique which encodes a message by inserting between its characters
randomly generated strings in a clever way. Because of pending patent issues we will not discuss in
detail how the strings are generated and inserted into the original message. To validate your method,
however, it is necessary to write a program that checks if the message is really encoded in the final
string.
Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove
characters from t such that the concatenation of the remaining characters is s.
Input
The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII
characters separated by whitespace. Input is terminated by EOF.
Output
For each test case output, if s is a subsequence of t.
Sample Input
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter
Sample Output
Yes
No
Yes
No

#include <iostream>
#include<cstring>
#include <iomanip>
#include<string>
using namespace std;
int main()
{
char a[100000], b[100000];
while (cin>>a>>b)
{
int len1 = strlen(a);
int len2 = strlen(b);
int i = 0, j = 0;
while (i<len1&&j<len2)
{
if (a[i] == b[j])
{
i++;
j++;
}
else { j++; }
}
if (i == len1)cout << "Yes" << endl;
else cout << "No" << endl;
}
}
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
思路:把两者的长度记录,比较,如果i的数值与长度相同,那么说明a所有字符在b可找到,注意,数组开始值为0,最后i++后刚好为长度
---------------------

posted @ 2019-07-10 01:05  水至清明  阅读(153)  评论(0编辑  收藏  举报