TOJ 1547

1547.   To and Fro
Time Limit: 1.0 Seconds   Memory Limit: 65536K
Total Runs: 885   Accepted Runs: 692



Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is "There's no place like home on a snowy night" and there are five columns, Mo would write down

t o i o y
h p k n n
e l e a i
r a h s g
e c o n h
s e m o t
n l e w x

Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character 'x' to pad the message out to make a rectangle, although he could have used any letter.

Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as

toioynnkpheleaigshareconhtomesnlewx

Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.

Input

There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2 ... 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.

Output

Each input set should generate one line of output, giving the original plaintext message, with no spaces.

Sample Input

5
toioynnkpheleaigshareconhtomesnlewx
3
ttyohhieneesiaabss
0

Sample Output

theresnoplacelikehomeonasnowynightx
thisistheeasyoneab
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
#include <iostream>
#include <cstring>
using namespace std;
int main()
{
    int i,j,k,T;
    char s[205];
    while(cin>>T,T)
    {
        memset(s,0,sizeof(s));
        cin>>s;
        int len = strlen(s);
        //二维字符数组申请
        int row = len/T;
        int col = T;
        char **str = new  char *[row];//  new  (char *)[row]会在编译器里CE
        for(i=0;i<row;i++)
            str[i] = new char[col];
        k = 0;
        for(i=0;i<row;i++)
        if((i&1)==0)//行号为0,2,4,加上括号,否则,恰好相反,汗
        {
            for(j=0;j<col;j++)
                str[i][j] = s[k++];
        }
        else
        {
            for(j=col-1;j>=0;j--)
                str[i][j] = s[k++];
        }
        /*
        for(i=0;i<row;i++)
        {
            for(j=0;j<col;j++)
                cout<<str[i][j];
            cout<<endl;
        }
        */
        //按要求输出
        for(i=0;i<col;i++)
            for(j=0;j<row;j++)
                cout<<str[j][i];//注意不是str[i][j]
        cout<<endl;
        //释放
        for(i=0;i<row;i++)
            delete []str[i];
        delete []str;
    }
    //system("pause");
    return 0;
}
          
         
        

 

posted @   加拿大小哥哥  阅读(205)  评论(0编辑  收藏  举报
(评论功能已被禁用)
编辑推荐:
· Java 中堆内存和栈内存上的数据分布和特点
· 开发中对象命名的一点思考
· .NET Core内存结构体系(Windows环境)底层原理浅谈
· C# 深度学习:对抗生成网络(GAN)训练头像生成模型
· .NET 适配 HarmonyOS 进展
阅读排行:
· 手把手教你更优雅的享受 DeepSeek
· 腾讯元宝接入 DeepSeek R1 模型,支持深度思考 + 联网搜索,好用不卡机!
· AI工具推荐:领先的开源 AI 代码助手——Continue
· 探秘Transformer系列之(2)---总体架构
· V-Control:一个基于 .NET MAUI 的开箱即用的UI组件库
点击右上角即可分享
微信分享提示