HDOJ 2055
Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
Give you a letter x and a number y , you should output the result of y+f(x).
Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.
Output
for each case, you should the result of y+f(x) on a line.
Sample Input
6
R 1
P 2
G 3
r 1
p 2
g 3
Sample Output
19
18
10
-17
-14
-4
#include<stdio.h>
int main()
{
int T,ans,d;
char ch;
scanf("%d", &T);
while(T--)
{
getchar();
//添加该句接收缓存中的换行或者其它字符,以免被赋值给x ,加上fflush(stdin)亦可
scanf("%c %d", &ch, &d);//字符型也需要取地址符
if(ch >= 65 && ch <= 90)
ch = ch - 64;
else if(ch >= 97 && ch <= 122)
ch = (ch - 96) * (-1);
ans = ch + d;
printf("%d\n", ans);
}
return 0;
}
作者:火星十一郎
本文版权归作者火星十一郎所有,欢迎转载和商用,但未经作者同意必须保留此段声明,且在文章页面明显位置给出原文连接,否则保留追究法律责任的权利.