7-8 估值一亿的AI核心代码

题目描述:

以上图片来自新浪微博。

本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:

  • 无论用户说什么,首先把对方说的话在一行中原样打印出来;
  • 消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
  • 把原文中所有大写英文字母变成小写,除了 I
  • 把原文中所有独立的 can youcould you 对应地换成 I canI could—— 这里“独立”是指被空格或标点符号分隔开的单词;
  • 把原文中所有独立的 I 和 me 换成 you
  • 把原文中所有的问号 ? 换成惊叹号 !
  • 在一行中输出替换后的句子作为 AI 的回答。

输入格式:

输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。

输出格式:

按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。

输入样例:

6
Hello ?
 Good to chat   with you
can   you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know

输出样例:

Hello ?
AI: hello!
 Good to chat   with you
AI: good to chat with you
can   you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don't know
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB

正则表达式代码实现:

#include<bits/stdc++.h>
using namespace std;
int main()
{
	int n;
	cin>>n;
	getchar();
	while(n--)
	{
		string str;
		getline(cin,str);
		cout<<str<<endl;
		str=regex_replace(str,regex(" +")," ");
		str=regex_replace(str,regex(" ([^\\w ])"),"$1");
		while(str[0]==' ') str.erase(str.begin());
		while(str.back()==' ') str.pop_back();
		for(int i=0;i<str.size();i++)
			if(str[i]>='A'&&str[i]<='Z'&&str[i]!='I')
				str[i]+=' ';
		//本来是要替换成I can的,但是为了防止下一步继续将I变成you
		//先替换成% can,后续再把%替换成I
		str=regex_replace(str,regex("\\bcan you\\b"),"% can");  
		str=regex_replace(str,regex("\\bcould you\\b"),"% could");
		str=regex_replace(str,regex("\\b(I|(me))\\b"),"you");
		for(int i=0;i<str.size();i++)
			if(str[i]=='?') str[i]='!';
			else if(str[i]=='%') str[i]='I';
		cout<<"AI: "<<str<<endl;
	}
	return 0;
}

模拟代码实现:

#include<iostream>
#include<vector>
using namespace std;
vector<char>v;
int main(){
    int t;
    cin>>t;
    getchar();
    while(t--){
        v.clear();
        string s;
        getline(cin,s);
        cout<<s<<endl;
        int flag=0;
        for(int i=0;i<s.size();i++){
            if(s[i]!=' ')flag=1;
            if(flag){
                if(s[i]>='A'&&s[i]<='Z'&&s[i]!='I'){
                    char c=s[i]+32;
                    v.push_back(c);
                }else if(s[i]==' '){
                    v.push_back(' ');
                    while(s[i]==' ')i++;
                    i--;
                }else if((s[i]>='0'&&s[i]<='9')||(s[i]>='a'&&s[i]<='z')||s[i]=='I')v.push_back(s[i]);
                else{
                    int t=v.size()-1;
                    while(t>0&&v[t]==' ')v.pop_back(),t--;
                    if(s[i]=='?')v.push_back('!');
                    else v.push_back(s[i]);
                }
            }
        }
        int t=v.size()-1;
        while(t>0&&v[t]==' ')v.pop_back(),t--;
        cout<<"AI: ";
        for(int i=0;i<v.size();i++){
            if(v[i]=='c'&&v[i+1]=='a'&&v[i+2]=='n'&&v[i+3]==' '&&v[i+4]=='y'&&v[i+5]=='o'&&v[i+6]=='u'&&i+6<v.size()){
                int flag=1;
                if((i>0&&((v[i-1]>='a'&&v[i-1]<='z')||(v[i-1]>='A'&&v[i-1]<='Z')||(v[i-1]>='0'&&v[i-1]<='9'))))flag=0;
                if((i+7<v.size()&&((v[i+7]>='a'&&v[i+7]<='z')||(v[i+7]>='A'&&v[i+7]<='Z')||(v[i+7]>='0'&&v[i+7]<='9'))))flag=0;
                if(flag){
                    cout<<"I can";
                    i=i+6;
                }else cout<<"c";
            }else if(v[i]=='c'&&v[i+1]=='o'&&v[i+2]=='u'&&v[i+3]=='l'&&v[i+4]=='d'&&v[i+5]==' '&&v[i+6]=='y'&&v[i+7]=='o'&&v[i+8]=='u'&&i+8<v.size()){
                int flag=1;
                if((i>0&&((v[i-1]>='a'&&v[i-1]<='z')||(v[i-1]>='A'&&v[i-1]<='Z')||(v[i-1]>='0'&&v[i-1]<='9'))))flag=0;
                if((i+9<v.size()&&((v[i+9]>='a'&&v[i+9]<='z')||(v[i+9]>='A'&&v[i+9]<='Z')||(v[i+9]>='0'&&v[i+9]<='9'))))flag=0;
                if(flag){
                    cout<<"I could";
                    i=i+8;
                }else cout<<"c";
            }else if(v[i]=='m'&&v[i+1]=='e'&&i+1<v.size()){
                int flag=1;
                if(i>0&&((v[i-1]>='a'&&v[i-1]<='z')||(v[i-1]>='A'&&v[i-1]<='Z')||(v[i-1]>='0'&&v[i-1]<='9')))flag=0;
                if(i+2<v.size()&&((v[i+2]>='a'&&v[i+2]<='z')||(v[i+2]>='A'&&v[i+2]<='Z')||(v[i+2]>='0'&&v[i+2]<='9')))flag=0;
                if(flag){
                    cout<<"you";
                    i=i+1;
                }else cout<<"m";
            }else if(v[i]=='I'){
                int flag=1;
                if(i>0&&((v[i-1]>='a'&&v[i-1]<='z')||(v[i-1]>='A'&&v[i-1]<='Z')||(v[i-1]>='0'&&v[i-1]<='9')))flag=0;
                if(i+1<v.size()&&((v[i+1]>='a'&&v[i+1]<='z')||(v[i+1]>='A'&&v[i+1]<='Z')||(v[i+1]>='0'&&v[i+1]<='9')))flag=0;
            	if(flag)cout<<"you"; 
                else cout<<"I";
			}
			else cout<<v[i];
        }
        cout<<endl;
    }
    return 0;
}

 

posted @ 2023-04-21 12:01  回忆、少年  阅读(19)  评论(0编辑  收藏  举报