L2-012 关于堆的判断

题目描述:

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T

代码展示:

#include<iostream>
#include<unordered_map>
#include<algorithm>
using namespace std;
const int MAX=1005;
unordered_map<int,int>p;
int h[MAX];
int N,M;
void up(int u){
	while(u/2>=1&&h[u/2]>h[u]){
		swap(h[u],h[u/2]);
		u/=2;
	}
}
int main(){
	cin>>N>>M;
	for(int i=1;i<=N;i++){
		cin>>h[i];
		up(i);
	}
	for(int i=1;i<=N;i++)p[h[i]]=i;
	string s;
	int x,y;
	while(M--){
		cin>>x>>s;
		if(s=="and"){
			cin>>y>>s>>s;
			if(p[x]/2==p[y]/2)cout<<"T"<<endl;
			else cout<<"F"<<endl;
		}else{
			string s1,s2,s3;
			cin>>s1>>s2;
			if(s2=="root"){
				if(p[x]==1)cout<<"T"<<endl;
				else cout<<"F"<<endl;
			}else if(s2=="parent"){
				cin>>s3>>y;
				if(p[y]/2==p[x])cout<<"T"<<endl;
				else cout<<"F"<<endl;
			}else{
				cin>>s3>>y;
				if(p[x]/2==p[y])cout<<"T"<<endl;
				else cout<<"F"<<endl;
			}
			
		}
		
	}
	
	return 0;
}

原题链接:PTA | 程序设计类实验辅助教学平

posted @ 2022-03-11 19:39  回忆、少年  阅读(13)  评论(0编辑  收藏  举报  来源