07:计算多项式的值
OpenJudge-1.3编程基础之算术表达式与顺序执行-07:计算多项式的值
总Time Limit: 1000ms Memory Limit: 65536kB
Description
对于多项式f(x) = ax3 + bx2 + cx + d 和给定的a, b, c, d, x,计算f(x)的值。
Input
输入仅一行,包含5个实数,分别是x,及参数a、b、c、d的值,每个数都是绝对值不超过100的双精度浮点数。数与数之间以一个空格分开。
Output
输出一个实数,即f(x)的值,保留到小数点后7位。
Sample Input
2.31 1.2 2 2 3
Sample Output
33.0838692
C++ Code
#include<iostream>
using namespace std;
int main()
{
double x,a,b,c,d,f;
cin>>x>>a>>b>>c>>d;
f=a*x*x*x+b*x*x+c*x+d;
cout<<fixed<<setprecision(7)<<f;
return 0;
}
C Code
#include<stdio.h>
int main()
{
double x,a,b,c,d,f;
scanf("%lf%lf%lf%lf%lf",&x,&a,&b,&c,&d);
f=a*x*x*x+b*x*x+c*x+d;
printf("%.7lf",f);
return 0;
}