团队队列(算法书上的)

题目代号:UVA 540

题目链接:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=481

题目

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example. In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue. Your task is to write a program that simulates such a team queue. Input The input file will contain one or more test cases. Each test case begins with the number of teams t (1 ≤ t ≤ 1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0..999999. A team may consist of up to 1000 elements. Finally, a list of commands follows. There are three different kinds of commands: • ENQUEUE x — enter element x into the team queue • DEQUEUE — process the first element and remove it from the queue • STOP — end of test case The input will be terminated by a value of 0 for t. Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time. Output Foreachtestcase, firstprintalinesaying‘Scenario #k’, where k isthenumberofthetestcase. Then, for each ‘DEQUEUE’ command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.

Sample Input 2 3 101 102 103 3 201 202 203 ENQUEUE 101 ENQUEUE 201 ENQUEUE 102 ENQUEUE 202 ENQUEUE 103 ENQUEUE 203 DEQUEUE DEQUEUE DEQUEUE DEQUEUE DEQUEUE DEQUEUE STOP 2 5 259001 259002 259003 259004 259005 6 260001 260002 260003 260004 260005 260006 ENQUEUE 259001 ENQUEUE 260001 ENQUEUE 259002 ENQUEUE 259003 ENQUEUE 259004 ENQUEUE 259005 DEQUEUE DEQUEUE ENQUEUE 260002 ENQUEUE 260003 DEQUEUE DEQUEUE DEQUEUE DEQUEUE STOP 0

Sample Output

Scenario #1 101 102 103 201 202 203
Scenario #2 259001 259002 259003 259004 259005 260001

题意

有t个团队的人正在拍一个长队,每次新来一个人时,如果他有队友在排队,那么这个新人会插队到最后一个队友的身边,如果没有任何一个队友排队,则他会排到长队的队尾

以下是三种指令:

ENQUEUE X        编号为x的人进入长队

DEQUEUE 长队的队首出队

STOP    停止模拟

 

 

解题思路:

队列的简单题,博主很懒的你应该知道

代码

7

 

 

#include<cstdio>
#include<iostream>
#include<map>
#include<queue>
using namespace std;
const int maxn=1000+10;
int main()
{
    int t,kase=0;
    while(scanf("%d",&t)==1&&t)
    {
        printf("Scenario #%d\n",++kase);
        map<int,int>team;//team[x]表示编号x的人所在的团队编号
        for(int i=0;i<t;i++)
        {
            int n,x;
            cin>>n;
            while(n--)
            {
                cin>>x;
                team[x]=i;
            }
        }
            //模拟
            queue<int>q,q2[maxn];//q是团队的队列 而q2【i】是团队i的成员队列
            while(1)
            {
                int x;
                char cmd[10];
                cin>>cmd;
                if(cmd[0]=='s')break;
                else if(cmd[0]=='D'){
                    int t=q.front();
                    cout<<q2[t].front()<<endl;
                    q2[t].pop();
                    if(q2[t].empty())q.pop();
                }
                else if(cmd[0]=='E')
                {
                    cin>>x;
                    int t=team[x];
                    if(q2[t].empty())q.push(t);//团队t进入队列
                    q2[t].push(x);
                }
            }
            cout<<endl;
        }
        return 0;
}

 

posted @ 2017-11-06 20:37  姿态H  阅读(522)  评论(0编辑  收藏  举报