第十二周作业
本周作业头
这次作业属于哪个课程 | C语言程序设计ll |
---|---|
这个作业要求在哪里 | https://edu.cnblogs.com/campus/zswxy/software-engineering-class1-2018/homework/3235 |
我在这个课程的目标是 | 学习一些指针与数组函数结构之间一些新的关系和应用 |
这个作业在哪个具体方面帮助我实现目标 | 将学到的东西结合运用到编程里面来 |
参考文献 | https://blog.csdn.net/qq_38846633/article/details/81165413 |
一、基础作业
题目1.计算最长的字符串长度
本题要求实现一个函数,用于计算有n个元素的指针数组s中最长的字符串的长度。
函数接口定义:
int max_len( char *s[], int n );
其中n个字符串存储在s[]中,函数max_len应返回其中最长字符串的长度。
裁判测试程序样例:
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define MAXN 10
#define MAXS 20
int max_len( char *s[], int n );
int main()
{
int i, n;
char *string[MAXN] = {NULL};
scanf("%d", &n);
for(i = 0; i < n; i++) {
string[i] = (char *)malloc(sizeof(char)*MAXS);
scanf("%s", string[i]);
}
printf("%d\n", max_len(string, n));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
4
blue
yellow
red
green
输出样例:
6
1).实验代码
int max_len( char *s[],int n )
{
int i,len,max=0;
for(i=0;i<n;i++)
{
len=strlen(s[i]);
if(len>max)
{
max=len;
}
}
return max;
}
2).设计思路
3).调试过程中遇到的问题和解决办法
刚开始觉得代码很复杂,后面理清楚之后发现并不难。
4).运行结果截图
题目2.统计专业人数
本题要求实现一个函数,统计学生学号链表中专业为计算机的学生人数。链表结点定义如下:
struct ListNode {
char code[8];
struct ListNode *next;
};
这里学生的学号共7位数字,其中第2、3位是专业编号。计算机专业的编号为02。
函数接口定义:
int countcs( struct ListNode *head );
其中head是用户传入的学生学号链表的头指针;函数countcs统计并返回head链表中专业为计算机的学生人数。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct ListNode {
char code[8];
struct ListNode *next;
};
struct ListNode *createlist(); /*裁判实现,细节不表*/
int countcs( struct ListNode *head );
int main()
{
struct ListNode *head;
head = createlist();
printf("%d\n", countcs(head));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1021202
2022310
8102134
1030912
3110203
4021205
#
输出样例:
3
1).实验代码
int countcs(struct ListNode *head)
{
int count=0;
while(head)
{
if(head->code[1]=='0'&&head->code[2]=='2')
{
count++;
}
head=head->next;
}
return count;
}
2).设计思路
3).调试过程中遇到的问题以及解决办法
while语句中条件错误,将while(1)改为while(head)后正确。
4).运行结果截图
题目3.删除单链表偶数节点
本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:
struct ListNode {
int data;
struct ListNode *next;
};
函数接口定义:
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
函数createlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。
函数deleteeven将单链表head中偶数值的结点删除,返回结果链表的头指针。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
struct ListNode {
int data;
struct ListNode *next;
};
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head )
{
struct ListNode *p = head;
while (p) {
printf("%d ", p->data);
p = p->next;
}
printf("\n");
}
int main()
{
struct ListNode *head;
head = createlist();
head = deleteeven(head);
printlist(head);
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1 2 2 3 4 5 6 7 -1
输出样例:
1 3 5 7
1).实验代码
struct ListNode *createlist()
{
struct ListNode *head,*p;
int n;
head=(struct ListNode *)malloc(sizeof(struct ListNode));
p=head;
head->next=NULL;
while(1)
{
p->next=(struct ListNode *)malloc(sizeof(struct ListNode));
scanf("%d",&n);
if(n==-1)
{
break;
}
p=p->next;
p-> data=n;
p->next=NULL;
}
head=head->next;
return (head);
}
struct ListNode *deleteeven(struct ListNode *head)
{
struct ListNode *p,*q;
if(head==NULL)
{
return NULL;
}
p=head;
q=p->next;
while(q!=NULL)
{
if(q->data%2==0)
{
p->next=q->next;
free(q);
q=p->next;
}
else
{
p=p->next;
q=p->next;
}
}
if(head->data%2==0)
{
head=head->next;
}
return (head);
}
2).设计思路
3).调试过程中遇到的问题和解决办法
刚开始以为这个题只需要定义删除节点的函数就可以了,后面翻笔记才发现老师上课的时候有详细讲过步骤,所以在定义删除节点的函数之前还得建立一个新的链表。
编程过程中还有很多小问题,比如循环语句结束的条件等等,不过最后还是照着书依葫芦画瓢写出来了。
4).运行结果截图
预习作业
1.所在小组想要开发的项目的名称和目标;
项目:一个小游戏
目标:可以完美的运行
2.项目主体功能的描述;
类似于贪食蛇这种游戏可以消磨时间。
3.现阶段已做的准备工作;
正在找资料
4.小组成员名单和进度安排。(课程设计阶段:13-17周)
小组成员:黄璇,谢鑫,陶祥庭,薛胜科。
二、学习进度条
周/日期 | 这周所花的时间 | 代码行 | 学到的知识点简介 | 目前比较疑惑的问题 |
---|---|---|---|---|
3/4-3/10 | 2天 | 38行 | 定义文件指针和文件数据的简单处理 | 对于文件数据的使用很手生 |
3/11-3/15 | 1天 | 24行 | 二维数组的定义和引用 | 强烈要求老师把这几次的题都讲解一下太多问题了 |
3/16-3/22 | 1天 | 37行 | 一些数组的简单算法 | 不知道二分法、选择排序法以及冒泡排序法的具体区别 |
3/23-3/29 | 1天 | 20行 | 复习了文件和字符型函数以及学习用字符串编程 | 文件使用的还不熟练敲代码的过程中老是出错还有不知道怎么表示字符串的长度 |
3/30-4/5 | 6h | 88行 | 复习自定义函数,指针变量的定义,指针变量的基本运算 | 指针与数组的关系 |
4/6-4/12 | 3h | 46行 | 将指针与数组结合运用到编程里边 | 代码稍微复杂点就不知道怎么使用指针了 |
4/13-4/19 | 8h | 38行 | 将指针数组字符串字符串函数结合使用到编程里边,预习了结构尝试着照着书上面的程序做了预习题 | 还是没有完全掌握冒泡排序算法 |
4/20-4/26 | 5h | 120行 | 将结构运用到编程里面 | 结构指针数组老是会混淆 |
5/6-5/10 | 4h | 26行 | 递归函数的使用 | 递归函数到底有什么用 |
5/11-5/17 | 6h | 81行 | 指针数组指针函数单向链表的一些常用操作 | 二级指针 |
三、学习感悟
感觉C语言以前学的东西都是小儿科,这个学期学的知识难度直线上升,快期末了还是有很多知识没有理解,敲代码的时候没有书简直就是寸步难行。学到的东西也零零碎碎,感觉都联系不到一块来。
四、结对编程总结
前面两题还相对简单,最后一题是在老师讲完课之后照着老师的课件模仿着写出来的,过程有点坎坷,中间还去看了一些别人写的代码,不过这种题的大概结构我已经理解了。
五、表格和折线图
周 | 代码行数 | 博客字数 |
---|---|---|
第一周 | 45行 | 536 |
第二周 | 38行 | 496 |
第三周 | 24行 | 757 |
第四周 | 37行 | 1239 |
第五周 | 20行 | 1179 |
第六周 | 88行 | 1688 |
第七周 | 46行 | 1528 |
第八周 | 38行 | 2091 |
第九周 | 120行 | 3744 |
第十一周 | 26行 | 3062 |
第十二周 | 81行 | 2059 |