[POJ 1269]Intersecting Lines

Intersecting Lines
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 16311   Accepted: 7040

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect. 
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000. 

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

题解:

详见大佬的博客

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
using namespace std;
int n;
double xx,yy;
struct Vector
{
    double x,y;
    Vector(){}
    Vector(double xx,double yy){x=xx;y=yy;}
    Vector operator+(Vector b)
    {
        Vector ans;
        ans.x=x+b.x;ans.y=y+b.y;
        return ans;
    }
    Vector operator-(Vector b)
    {
        Vector ans;
        ans.x=x-b.x;ans.y=y-b.y;
        return ans;
    }
    double operator*(Vector b)
    {
        return x*b.y-b.x*y;
    }
    double operator^(Vector b)
    {
        return x*b.x+y*b.y;
    }
};
struct node
{
    Vector a,b;
}s,t;
int main()
{
    int i,j;
    scanf("%d",&n);
    printf("INTERSECTING LINES OUTPUT\n");
    for(i=1;i<=n;i++)
    {
        scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&s.a.x,&s.a.y,&s.b.x,&s.b.y,&t.a.x,&t.a.y,&t.b.x,&t.b.y);
        if(s.a.x==s.b.x||t.a.x==t.b.x)
        {
            if(s.a.x-s.b.x==t.a.x-t.b.x)
            {
                if(s.a.x==t.a.x)printf("LINE\n");
                else printf("NONE\n");
            }
            else
            {
                if(s.a.x-s.b.x==0)
                {
                    printf("POINT %.2lf %.2lf\n",s.a.x,(s.a.x-t.a.x)*((t.b.y-t.a.y)/(t.b.x-t.a.x))+t.a.y);
                }
                else
                {
                    printf("POINT %.2lf %.2lf\n",t.a.x,(t.a.x-s.a.x)*((s.b.y-s.a.y)/(s.b.x-s.a.x))+s.a.y);
                }
            }
            continue;
        }
        if((s.b.y-s.a.y)/(s.b.x-s.a.x)!=(t.b.y-t.a.y)/(t.b.x-t.a.x))
        {
            double tmp=fabs((s.a-t.a)*(t.a-t.b));
            tmp=tmp/(tmp+fabs((s.b-t.a)*(t.a-t.b)));
            xx=(s.b.x-s.a.x)*tmp+s.a.x;yy=(s.a.y-s.b.y)*(1-tmp)+s.b.y;
            printf("POINT %.2lf %.2lf\n",xx,yy);
        }
        else
        {
            if((s.a-s.b)*(t.a-s.b)==0)printf("LINE\n");
            else printf("NONE\n");
        }
    }
    printf("END OF OUTPUT\n");
    return 0;
}

 

posted @ 2017-08-01 21:16  kakakakakaka  阅读(126)  评论(0编辑  收藏  举报

Never forget why you start

//鼠标爆炸特效