Live2d Test Env

HDU2057 A + B Again


Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !
 

Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.
 

Output
For each test case,print the sum of A and B in hexadecimal in one line.
 

Sample Input
+A -A +1A 12 1A -9 -1A -12 1A -AA
 

Sample Output
0 2C 11 -2C -90
 

Author
linle
 

Source

HDU2057
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
using namespace std;
int main()
{
	 long long  a,b;
	 while(~scanf("%llX%llX",&a,&b)){
			if(a+b<0) {
				a=-a;b=-b;
				cout<<"-";
			}
			printf("%llX\n",a+b);
	 }
	 return 0;
}
("%X",a)表示16进制处理a,x时是小写



posted @ 2017-09-27 21:06  nimphy  阅读(205)  评论(0编辑  收藏  举报