1651: [Usaco2006 Feb]Stall Reservations 专用牛棚

Description

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows. Help FJ by determining: * The minimum number of stalls required in the barn so that each cow can have her private milking period * An assignment of cows to these stalls over time

有N头牛,每头牛有个喝水时间,这段时间它将专用一个Stall 现在给出每头牛的喝水时间段,问至少要多少个Stall才能满足它们的要求

Input

* Line 1: A single integer, N

* Lines 2..N+1: Line i+1 describes cow i's milking interval with two space-separated integers.

Output

* Line 1: The minimum number of stalls the barn must have.

* Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.

Sample Input

5
1 10
2 4
3 6
5 8
4 7

Sample Output

4


OUTPUT DETAILS:

Here's a graphical schedule for this output:

Time 1 2 3 4 5 6 7 8 9 10
Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>
Stall 2 .. c2>>>>>> c4>>>>>>>>> .. ..
Stall 3 .. .. c3>>>>>>>>> .. .. .. ..
Stall 4 .. .. .. c5>>>>>>>>> .. .. ..

Other outputs using the same number of stalls are possible.

HINT

 

不妨试下这个数据,对于按结束点SORT,再GREEDY的做法 1 3 5 7 6 9 10 11 8 12 4 13 正确的输出应该是3

 
明明是一道水题。。。。结果硬生生爆了内存
因为开始的代码是这样的
 for(int i=1;i<=n;i++){
        scanf("%d%d",&b[i],&c[i]);
    }
    build(1,1,1000010);
    for(int i=1;i<=n;i++)add(1,b[i],c[i],1);

之后发现其实不需要b,c数组,然后就过了,我不会说我在电脑上对拍爆栈了。。。。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
#define MAX 1000010
#define maxn 50010
#define inf 100000000
#define ll long long
using namespace std;
struct tree{
    int l,r,mx,lazy;
}f[MAX*4];
int b,c;
void pushup(int i){
    f[i].mx=max(f[i*2+1].mx,f[i*2].mx);
}
  
void update(int i,int x)
{
    f[i].mx+=x;
    f[i].lazy+=x;
    return;
}
  
void pushdown(int i){
    if(f[i].lazy!=0){
        update(i*2,f[i].lazy);
        update(i*2+1,f[i].lazy);
        f[i].lazy=0;
        return;
    }
    else return;
}
  
void build(int i,int left,int right){
    int mid=(left+right)/2;
    f[i].lazy=0;f[i].mx=0;
    f[i].l=left;f[i].r=right;
    if(left==right){
        f[i].mx=0;
        return;
    }
    build(i*2,left,mid);
    build(i*2+1,mid+1,right);
    pushup(i);
}
  
void add(int i,int left,int right,int v){
    int mid=(f[i].l+f[i].r)/2;
    if(f[i].l==left&&f[i].r==right){
        update(i,v);
        return;
    }
    pushdown(i);
    if(mid>=right)add(i*2,left,right,v);  
    else if(mid<left)add(i*2+1,left,right,v);
    else {add(i*2,left,mid,v);add(i*2+1,mid+1,right,v);};
    pushup(i);
}
 
int qmax(int i,int left,int right){
    int mid=(f[i].l+f[i].r)/2;
    if(f[i].l==left&&f[i].r==right) return f[i].mx;
    pushdown(i);
    if(mid>=right) return qmax(i*2,left,right);
    if(mid<left) return qmax(i*2+1,left,right);
    return max(qmax(i*2,left,mid),qmax(i*2+1,mid+1,right));
}
 
int main(){
    int n;
    scanf("%d",&n);
    build(1,1,1000010); 
    for(int i=1;i<=n;i++){
        //printf("%d",i);
        scanf("%d%d",&b,&c);
        add(1,b,c,1);
    }
     
    printf("%d",qmax(1,1,1000010));
}

 

posted @ 2015-10-03 14:38  HTWX  阅读(143)  评论(0编辑  收藏  举报