poj2503--Babelfish(特里一水)

Babelfish
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 32988   Accepted: 14189

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.

Source

Waterloo local 2001.09.22
输入一个字典。前面一个单词和后面的单词映射。问给出的单词有没有相应的,有输出,没有,输出eh
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct node{
    int flag ;
    node *next[27] ;
} *head;
node *getnode()
{
    node *p = new node ;
    int i ;
    for(i = 0 ; i < 27 ; i++)
        p->next[i] = NULL ;
    p->flag = -1 ;
    return p ;
}
void gettree(node *p,char *s,int m)
{
    int i , k , l = strlen(s);
    for(i = 0 ; i < l ; i++)
    {
        k = s[i] - 'a' ;
        if( p->next[k] == NULL )
            p->next[k] = getnode();
        p = p->next[k] ;
    }
    p->flag = m ;
}
int f(node *p,char *s)
{
    int i , k , l = strlen(s) ;
    for(i = 0 ; i < l ; i++)
    {
        k = s[i] - 'a' ;
        if( p->next[k] == NULL )
            return -1 ;
        p = p->next[k] ;
    }
    return p->flag;
}
char s1[110000][12] , s2[110000][12] , s[30] ;
int main()
{
    int i = 0 , j , l , k ;
    head = getnode();
    while(1)
    {
        gets(s);
        if(s[0] == '\0')
            break;
        sscanf(s,"%s %s", s1[i], s2[i]);
        gettree(head,s2[i],i);
        i++ ;
    }
    while(gets(s)!=NULL)
    {
        if(s[0] == '\0')
            break;
        k = f(head,s);
        if(k == -1)
            printf("eh\n");
        else
            printf("%s\n", s1[k]);
    }
    return 0;
}

版权声明:转载请注明出处:http://blog.csdn.net/winddreams

posted @ 2015-09-29 12:17  hrhguanli  阅读(174)  评论(0编辑  收藏  举报