杭电 1711 Number Sequence

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10239    Accepted Submission(s): 4656


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
6 -1


经典 kmp。

AC代码例如以下:

#include<iostream>
#include<cstdio>
using namespace std;
int a[1000005],b[10005],next[10005];
int main()
{
    int t;
    int n,m,ans;
    int i,j;
    scanf("%d",&t);
    while(t--)
    {
        ans=-1;
        scanf("%d%d",&n,&m);
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(i=0;i<m;i++)
            scanf("%d",&b[i]);
        i=0;j=-1;next[0]=-1;
        while(i<m)
        {
            if(j==-1||b[i]==b[j])
                next[++i]=++j;
            else
                j=next[j];
        }
        i=0;j=0;
        while(i<n&&j<m)
        {
            if(j==-1||a[i]==b[j])
            i++,j++;
            else j=next[j];
            if(j==m)
            {
                ans=i-j+1;break;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}




posted @ 2014-08-27 12:18  hrhguanli  阅读(195)  评论(0编辑  收藏  举报