The Triangle
- 描述
-
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
- 输入
- Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
- 输出
- Your program is to write to standard output. The highest sum is written as an integer.
- 样例输入
-
5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
- 样例输出
-
30
-
#include<iostream>
#include<cstring>
using namespace std;
#define N 100int d[N][N];
int a[N][N];
int n;
int dp(int i,int j)
{
if(d[i][j]>0) return d[i][j];
if(i==n) return a[i][j];
if(dp(i+1,j)>dp(i+1,j+1))
return d[i][j]=a[i][j]+dp(i+1,j);
else return d[i][j]=a[i][j]+dp(i+1,j+1);
}int main()
{
int i,j;cin>>n;
for(i=1;i<=n;i++)
for(j=1;j<=i;j++)
cin>>a[i][j];
memset(d,-1,sizeof(d));
for(j=1; j<=n; j++) d[n][j]=a[n][j];
d[1][1]=dp(1,1);
cout<<d[1][1]<<endl;return 0;
}