[POJ2436] Disease Management

Description

Alas! A set of D (1 <= D <= 15) diseases (numbered 1..D) is running through the farm. Farmer John would like to milk as many of his N (1 <= N <= 1,000) cows as possible. If the milked cows carry more than K (1 <= K <= D) different diseases among them, then the milk will be too contaminated and will have to be discarded in its entirety. Please help determine the largest number of cows FJ can milk without having to discard the milk.

Input

  • Line 1: Three space-separated integers: N, D, and K

  • Lines 2..N+1: Line i+1 describes the diseases of cow i with a list of 1 or more space-separated integers. The first integer, d_i, is the count of cow i's diseases; the next d_i integers enumerate the actual diseases. Of course, the list is empty if d_i is 0.

Output

  • Line 1: M, the maximum number of cows which can be milked.

Sample Input

6 3 2
0
1 1
1 2
1 3
2 2 1
2 2 1

Sample Output

5

Hint

OUTPUT DETAILS:

If FJ milks cows 1, 2, 3, 5, and 6, then the milk will have only two diseases (#1 and #2), which is no greater than K (2).

Source

USACO 2005 U S Open Silver

题意

题解

位运算优化\(Dfs\),由于病毒的种类比较小,所以我们枚举每一种病毒选与不选,再统计即可。

#include<iostream>
#include<cstdio>
using namespace std;

const int N=1001,D=20;
int n,d,k,Ans;
int two[D],cow[N];

void Dfs(int id,int pre,int nw)//id为当前正在处理的病毒,pre表示已经选的病毒数,nw用二进制表示选病毒的状态
{
	if(d-id+1<k-pre) return;//优化,若有剩余的病毒可选,则一定不是最优
	if(pre==k)
	{
		int Res=0;
		for(int i=1;i<=n;++i)
			if(cow[i]==(cow[i]&nw)) ++Res;//该奶牛可选
		Ans=max(Ans,Res);
		return;
	}
	Dfs(id+1,pre,nw),//不选该病毒
	Dfs(id+1,pre+1,nw|=two[id]);//选该病毒
}

int main()
{
	scanf("%d%d%d",&n,&d,&k);
	two[1]=1;
	for(int i=2;i<=d;++i) two[i]=two[i-1]<<1;
	int cas,w;
	for(int i=1;i<=n;++i)
		for(scanf("%d",&cas);cas;--cas)
			scanf("%d",&w),cow[i]|=two[w];
	Dfs(1,0,0),printf("%d\n",Ans);
	return 0;
}
posted @ 2019-08-21 10:08  OItby  阅读(153)  评论(0编辑  收藏  举报