poj 3617 Best Cow Line

http://poj.org/problem;jsessionid=F0726AFA441F19BA381A2C946BA81F07?id=3617

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD


这个题说的是一个人有一群牛,要去参加比赛,每头牛都有名字,报名的时候只登记名字的首字母,但是这个人比赛当天有急事要回去,所以就想先比赛,而比赛是按字典序来安排的,所以它的字典序越小就越靠
前,这个人要组成一个比较小的字符串,他可以把原来的字符串的头部删除放在新的字符串的末尾,也可以把原来字符串的尾部删除放在新的的尾部,大致就是这个意思
然后书上说只要前面的比较小就行,然后就是不断地取开头和末尾放在新的字符串的尾部,
书上还说,字典序比较S和反转后的字符串S‘,如果S比较小就从S的开头取一个字符,如果S’的比较小,就取S‘的
但是!!!!我理解错了啊!!!我理解成一个字符串反转,然后对于每一个进行比较,较小的拿出来
就是 ACDBCB
反转后 BCBDCA
然后A跟B比,A比较小,就取A,C跟C比,取C,D跟B比取B,然后就得到了ACBBCA,哎,我还一直纠结为什么答案不对

#include<cstdio>
int main()
{
    int n;
    char s[2000],c[2000];
    char t[2000];
    scanf("%d",&n);
    getchar();//输入%d(也就是数字)后面肯定有回车或者空格你要打,那么缓冲区就有\n或者空格字符遗留,%c 读取是从缓冲区读取的,那么优先读取的是\n,就错了,getchar()读掉遗留的就行了
    for(int i=0;i<n;i++)
    {
        scanf("%c",&s[i]);
    }
    for(int i=n-1;i>=0;i--)
    {

       c[n-i-1]=s[i];//这个我测试的时候一直输出少一个,原来是因为getchar()
    }
    for(int i=0;i<n;i++)
    {
       if(s[i]<=c[i])
           t[i]=s[i];
       if(s[i]>c[i])
           t[i]=c[i];
    }
    for(int i=0;i<n;i++)
        printf("%c",t[i]);
    printf("\n");
    return 0;
}

虽然写了一大堆,但是不对,不过没关系,至少是自己写的啊

#include<cstdio>
int main()
{
    int n;
    char s[2000];
    scanf("%d",&n);
    getchar();//输入%d(也就是数字)后面肯定有回车或者空格你要打,那么缓冲区就有\n或者空格字符遗留,%c 读取是从缓冲区读取的,那么优先读取的是\n,就错了,getchar()读掉遗留的就行了
    for(int i=0;i<n;i++)
    {
        scanf("%c",&s[i]);
    }
    int a=0,b=n-1;
    while(a<=b)
    {
        bool left=false;
        for(int i=0;a+i<=b;i++)
        {
            if(s[i+a]<s[b-i])
            {
                left=true;
                break;
            }
            else if(s[a+i]>s[b-i])
            {
                left=false;
                break;
            }
        }
        if(left)
            putchar(s[a++]);
        else
            putchar(s[b--]);
    }
    putchar('\n');
    return 0;
}这个按书上打的计较不行,presentation error

这个我感觉主要是Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line的问题

然后我就上网查了别人的代码,但是现在有事,明天再补,我习惯想到一点补一点,以前没人看,我怎样写都无所谓,但是现在有人看了,还是谨慎一点吧

 果然就是那个问题

#include<cstdio>
int main()
{
    int n,num;
    char s[2000];
    while(scanf("%d",&n)==1)
    {
        num=0;
        for(int i=0;i<n;i++)
        {   getchar();
            scanf("%c",&s[i]);
        }
        int a=0,b=n-1;
        while(a<=b)
        {
            bool left=false;
            for(int i=0;a+i<=b;i++)//这个是为了防止一样的情况
            {
                if(s[i+a]<s[b-i])
                {
                    left=true;
                    break;
                }
                else if(s[a+i]>s[b-i])
                {
                    left=false;
                    break;
                }
            }
            if(left)
                putchar(s[a++]);//a和b的值在不断变化
            else
                putchar(s[b--]);
            num++;
            if(num%80==0)
                puts(" ");
        }
        putchar('\n');
    }
    return 0;
}这样就对了

posted @ 2016-08-15 12:40  小小姐  阅读(177)  评论(0编辑  收藏  举报