poj 1005 I Think I Need a Houseboat

Description

Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion.
After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.)

Input

The first line of input will be a positive integer indicating how many data sets will be included (N). Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.

Output

For each data set, a single line of output should appear. This line should take the form of: “Property N: This property will begin eroding in year Z.” Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer. After the last data set, this should print out “END OF OUTPUT.”

Sample Input

2
1.0 1.0
25.0 0.0

Sample Output

Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.

Hint

1.No property will appear exactly on the semicircle boundary: it will either be inside or outside.  2.This problem will be judged automatically. Your answer must match exactly, including the capitalization, punctuation, and white-space. This includes the periods at the ends of the lines.  3.All locations are given in miles.
这个题首先是不懂他什么意思,后来半知半解,也大致打出来代码了,结果不对,20对了1不对,我的第一组输出是0,我知道要输出一,然后我就加一个1,但是这样第二组就不对了,然后我就搜了别人的代码(我又看别人的代码!!!!!!),然后他写的输出跟我不一样
#include<cstdio>
#include<cmath>
int main()
{
    int n;
    float x,y,r,s;
    scanf("%d",&n);
    float pi=acos(-1);
    for(int i=1;i<=n;i++)
    {
        scanf("%f%f",&x,&y);
        r=x*x+y*y;
        s=pi*r/100;
        printf("Property %d: This property will begin eroding in year %d.\n",i,(int)s+1);//别人是这么输出的,但是我是%.0f,然后s+1,
    }
    printf("END OF OUTPUT.\n");
    return 0;
}
我去问问为什么不对,有什么区别
可以写个小程序自己体会一下,就是如果是%.xf,就是在小数点后面x+1会四舍五入,但是int就是直接舍弃
posted @ 2016-07-25 15:45  小小姐  阅读(69)  评论(0编辑  收藏  举报