Money Systems

The cows have not only created their own government but they have chosen to create their own money system. In their own rebellious way, they are curious about values of coinage. Traditionally, coins come in values like 1, 5, 10, 20 or 25, 50, and 100 units, sometimes with a 2 unit coin thrown in for good measure.

The cows want to know how many different ways it is possible to dispense a certain amount of money using various coin systems. For instance, using a system of {1, 2, 5, 10, ...} it is possible to create 18 units several different ways, including: 18x1, 9x2, 8x2+2x1, 3x5+2+1, and many others.

Write a program to compute how many ways to construct a given amount of money using supplied coinage. It is guaranteed that the total will fit into both a signed long long (C/C++) and Int64 (Free Pascal).

PROGRAM NAME: money

INPUT FORMAT

The number of coins in the system is V (1 <= V <= 25).

The amount money to construct is N (1 <= N <= 10,000).

Line 1: Two integers, V and N
Lines 2..: V integers that represent the available coins (no particular number of integers per line)

SAMPLE INPUT (file money.in)

3 10
1 2 5

OUTPUT FORMAT

A single line containing the total number of ways to construct N money units using V coins.

SAMPLE OUTPUT (file money.out)

10
很经典的dp问题,可以自己多想一下。
我的方法有些奇怪,而且不是最优的,但是此题不是作为重点,可以用于练手,调剂。
这样的问题,对于初学者,往往是值得思索的。
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int n,m;
int num[50];
long long ans,dp[26][10005];
int main()
{
    freopen("money.in","r",stdin);
    freopen("money.out","w",stdout);
    int i,j,k;
    scanf("%d%d",&n,&m);
    for(i=1;i<=n;++i) scanf("%d",&num[i]);
    for(i=0;i<=m/num[1];++i) dp[1][m-i*num[1]]=1;
    if(m%num[1]==0) ans++;
    for(i=2;i<=n;++i)
    {
        for(j=0;j<=m;++j)
        {
            for(k=0;k<=m/num[i]+1;++k)
            {
                if(k==0&&j==0) continue;
                if(j+k*num[i]<=m)
                {
                    dp[i][j]+=dp[i-1][j+k*num[i]];
                }
            }
            if(j==0) ans+=dp[i][j];
        }
    }
    cout<<ans<<"\n";
    return 0;
}