博客园 首页 私信博主 显示目录 隐藏目录 管理

I题 - A+B for Input-Output Practice (VIII)

 
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
 

Description

Your task is to calculate the sum of some integers. 
 

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 
 

Output

For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs. 
 

Sample Input

3
4 1 2 3 4
5 1 2 3 4
5 3 1 2 3
 

Sample Output

10
 
15
 
6
 注意格式,案例输出结果之间都要有一个空行
 
#include<stdio.h>
int main()
{
    int T,n,a;
    scanf("%d",&T);
    while(T--)
    {
        int sum=0;
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a);
            sum=sum+a;
        }
        printf("%d\n",sum);
        if(T) printf("\n");
    }
    return 0;
}

 

posted @ 2015-10-15 19:27  hfcnal  阅读(1587)  评论(0编辑  收藏  举报